If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Enhancement : Implement a special storage system for SSD's

RESOLVED DUPLICATE of bug 727409

Status

()

Core
Networking: Cache
--
enhancement
RESOLVED DUPLICATE of bug 727409
5 years ago
3 years ago

People

(Reporter: Mayank Bansal, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130315 Firefox/22.0
Build ID: 20130315030943

Steps to reproduce:

As the number of users using SSD's are increasing,  it could be a perf win to implement a special storage system for SSD's.  Something like

1. Assuming writes have been written to the disk without confirmation.
2. No fsync or something.
3. Assuming data will be read from the disk instantanously, so start rendering.
4. Less locking the mainthread.

I know these are very very vague points.  If they can give a perf difference for SSD users only, this could possibly be looked into.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement

Comment 1

5 years ago
Cache is being rewritten: https://wiki.mozilla.org/Necko/Cache/Plans
Component: Untriaged → Networking: Cache
Product: Firefox → Core
(Reporter)

Comment 2

3 years ago
is this  under consideration ?

Updated

3 years ago
Blocks: 727409
YF, I think this is really a duplicate of bug 727409 beause the reporter is just collecting different ideas.  It may be better for the reporter to file individual, actionable issues and make them block 727409.  

#4 is already covered in other bug reports.  I think to some extent #2 is also covered. #1 and #3 perhaps not - I'm not sure.

Comment 4

3 years ago
Right, I also had doubts but did not do it, I'm done it now.
No longer blocks: 727409
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 727409
You need to log in before you can comment on or make changes to this bug.