All users were logged out of Bugzilla on October 13th, 2018

you cannot combine the navigator.id.watch() API with navigator.id.getVerifiedEmail() or navigator.id.get()

RESOLVED FIXED

Status

()

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

Production
x86
Mac OS X

Details

(Assignee)

Description

6 years ago
we got a report of the following error:

[01:28:32.915] navigator.id.getVerifiedEmail has been deprecated
--
[01:28:40.463] Error: you cannot combine the navigator.id.watch() API with navigator.id.getVerifiedEmail() or navigator.id.get()this site should instead use navigator.id.request() and navigator.id.watch() @ https://login.persona.org/include.js:8

i'm unable to reproduce this error, however we are indeed using both watch() and getVerifiedEmail().

Comment 1

6 years ago
firefox aurora 21.0a2 (2013-03-17)
(Assignee)

Comment 2

6 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified .htaccess
modified Bugzilla.pm
modified extensions/Persona/template/en/default/hook/account/create-additional_methods.html.tmpl
Committed revision 8666.

oops, accidental commits

Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified .htaccess
modified Bugzilla.pm
Committed revision 8667.

you didn't see a thing.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.