[TSF] MetroWidget hasn't implemented GetIMEUpdatePreference()

RESOLVED FIXED in mozilla22

Status

()

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({inputmethod})

Trunk
mozilla22
x86_64
Windows 8.1
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 726000 [details] [diff] [review]
Patch

MetroWidget doesn't implemented nsIWidget::GetIMEUpdatePreference(). This causes nsIMEStateManager doesn't create nsTextStateManager. Then, neither NotifyIME(NOTIFICATION_OF_FOCUS), NotifyIME(NOTIFICATION_OF_BLUR), NotifyIME(NOTIFICATION_OF_SELECTIONCHANGE) nor NotifyIME(NOTIFICATION_OF_FOCUS) is called.

By this bug, nsTextStore never resets cached selection. Therefore, for example, if you try to input "Metro" without TIP and "アプリ" with TIP, then, the "ア" is inserted before "M" because nsTextStore thinks the caret position still stays before "M".

The behavior may be a regression of bug 790516.
Attachment #726000 - Flags: review?(jmathies)

Updated

6 years ago
Attachment #726000 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/5e115ca28105
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.