Demystify add-on file layout in generated .xpi

RESOLVED DUPLICATE of bug 915376

Status

Add-on SDK
General
P2
normal
RESOLVED DUPLICATE of bug 915376
5 years ago
4 years ago

People

(Reporter: irakli, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

At the moment there is bunch of layout changes done by cfx for add-on. It adds more directories etc... This also apparently causes file paths to exceed limits on windows as reported by myk.

We should just preserve original package layout do no magic transforms so it's simple intuitive and short.
@ochameau wanna tackle this ?

Updated

5 years ago
Priority: -- → P2
Can we close this due to bug 915376 ?
Flags: needinfo?(rFobic)
(In reply to Erik Vold [:erikvold] [:ztatic] from comment #2)
> Can we close this due to bug 915376 ?

I would actually make this subtask of that, but sure you can mark this as a dupe instead.
Flags: needinfo?(rFobic)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 915376
Resolution: --- → DUPLICATE
Duplicate of bug: 915376
You need to log in before you can comment on or make changes to this bug.