Mouse events are not going to Composer when clicking on "input" element in a page being edited.

VERIFIED DUPLICATE of bug 82547

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 82547
17 years ago
17 years ago

People

(Reporter: Kathleen Brade, Assigned: rubydoo123)

Tracking

Trunk
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
If I have a document in Composer with input and/or textarea tags, I can't bring 
up the advanced properties editor for those by double-clicking on them.  I can't 
bring up a context menu on them either.

Comment 1

17 years ago
We have a dup of this somewhere, I think.

Comment 2

17 years ago
I agree with Simon, I think this is a known problem.
Original summary for this was: "unable to bring up advanced editor for input
and textarea"
The reason is that mouse events (right or left click, Ctrl+Click on Mac,
and double click are not going to the editor that contains the "input" element
in a page that is being edited.
Note that in Windows, right-click does bring up the context menu, so the
mouse eventlistener for context menus is getting the event correctly.
But Composer also has a mouse event listener that should be getting the event
first. Maybe whatever we did to prevent the underlying editor associated with
the input element from being active has blocked events?
Summary: unable to bring up advanced editor for input and textarea → Mouse events are not going to Composer when clicking on "input" element in a page being edited.
(Assignee)

Comment 3

17 years ago
i think this is a dup of 82547

Comment 4

17 years ago
That's the one.


*** This bug has been marked as a duplicate of 82547 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.