No UI for downloading <embed>ded files without plug-in

VERIFIED DUPLICATE of bug 83754

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 83754
17 years ago
16 years ago

People

(Reporter: hsivonen, Assigned: rubydoo123)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Steps to reproduce:
1) Load a page that requires a plug-in that you don't have. For exapmle, head
over to http://www.apple.com/trailer/ without the QuickTime plug-in.

Actual results (with plug-in downloader plug-in installed):
You see a rectange with some text and an icon in it. The text tells you to
install the plug-in and then click here. Can't invoke the context menu.

Actual results (build with no plug-in support or without the plug-in downloader
plug-in):
You see an empty space reserved for the <embed>ded content and possibly a dialog
telling you to get the plug-in downloader plug-in. The context-menu provides no
useful items for dealing with the situation.

Expected results:
Expected to have some way (eg. via a context menu) for initiating a download of
the <embed>ded file and for copying the URL of the <embed>ded file.

Comment 1

17 years ago
See bug 83754 about replacing the C++ default plugin with an XBL one. It can now
be extended with Javascript.

Comment 2

17 years ago
Does this solve the problem for the case of no plugin support?

Comment 3

17 years ago
Oops, a more careful reading shows that bug 83754 should handle the case of no
plugin support, perhaps better than our current support.
Depends on: 83754

Comment 4

16 years ago
.
Assignee: mpt → beppe
Component: User Interface Design → Plug-ins
QA Contact: zach → shrir
(Assignee)

Comment 5

16 years ago
Peter: is this a dup of bug 83754, or is this a dependent on bug 83754, or neither?

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 83754 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.