Closed Bug 853022 Opened 8 years ago Closed 8 years ago

Remove "Ideas" from feedback app

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 22
Tracking Status
firefox21 --- verified
firefox22 --- verified

People

(Reporter: tdowner, Assigned: Margaret)

Details

Attachments

(1 file)

With Input 2.0, the ideas category is going away. We should remove this option from the feedback solicitation app or else all Ideas will be thrown into Sad, possibly skewing the data.
That's a good idea.
Attached patch patchSplinter Review
Maybe we should get some UX feedback on whether or not we want to update this now that there's only 2 options, but this is the simple solution.

I also just noticed that the footer goes off screen the first time about:feedback is opened - seems like a dynamic toolbar bug.
Assignee: nobody → margaret.leibovic
Attachment #727364 - Flags: review?(mark.finkle)
Comment on attachment 727364 [details] [diff] [review]
patch

Looks good
Attachment #727364 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/389667c99555
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
Can we get this uplifted to 20 or 21? The new input will be launching soon, so the faster we can get this into release the better. Thanks for the prompt turnaround.
Comment on attachment 727364 [details] [diff] [review]
patch

I think it's probably too late to land this on beta, although it is extremely low risk, so maybe we could squeeze it in? For now, I'm just requesting aurora approval.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: users will think they're submitting idea feedback, but it will really just get lumped in with sad feedback when the new input.mozilla.org goes live
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low-risk, deletes an option from about:feedback
String or UUID changes made by this patch: n/a (only removals)
Attachment #727364 - Flags: approval-mozilla-aurora?
Comment on attachment 727364 [details] [diff] [review]
patch

low risk patch and given the ideas will not be of any help the new Input goes live, we are just removing that option for users
Attachment #727364 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(In reply to Tyler Downer [:Tyler] from comment #6)
> Can we get this uplifted to 20 or 21? The new input will be launching soon,
> so the faster we can get this into release the better. Thanks for the prompt
> turnaround.

A quick spotcheck with the new input(hoping it will be landed by Fx21 release) once this lands will be helpful :) Thanks in advance for your help !
Verified fixed on:
Build: Firefox for Android 23.0a1 (2013-04-21) and Firefox for Android 22.0a2 (2013-04-21)
Device: LG Nexus 4
OS: Android 4.2.2
Status: RESOLVED → VERIFIED
Verified on Firefox for Android 21.0b7 and Aurora 22.0a2 (2013-05-07) using: Nexus 4 (4.2.2)
You need to log in before you can comment on or make changes to this bug.