Note: There are a few cases of duplicates in user autocompletion which are being worked on.

nsIPrintSettings should have IID revved

RESOLVED FIXED in Firefox 21

Status

()

Core
Printing: Output
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: bajaj, Assigned: Julian Viereck)

Tracking

(Blocks: 1 bug, {dev-doc-needed})

Trunk
mozilla22
dev-doc-needed
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox20 wontfix, firefox21+ fixed, firefox22+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
http://hg.mozilla.org/mozilla-central/rev/8de609c5d378 changeset (Bug 743252 ) missed the IID change with the  interface nsIPrintSettings : nsISupports being modified
Component: DOM → Printing: Output
Assignee: nobody → jviereck.dev
(Reporter)

Updated

4 years ago
Blocks: 853037
(Reporter)

Updated

4 years ago
No longer blocks: 853037
(Reporter)

Updated

4 years ago
Blocks: 851302

Updated

4 years ago
Blocks: 743252
(Reporter)

Updated

4 years ago
status-firefox21: --- → affected
tracking-firefox21: --- → +
(Reporter)

Comment 1

4 years ago
Julian, looks like the patch (Bug 743252 ) adds a new attribute in "b/widget/nsIPrintSettings.idl" . Does IID need to be revved in this case ? If so can you please help with a patch asap.
Flags: needinfo?(jviereck.dev)
(Assignee)

Comment 2

4 years ago
Created attachment 729497 [details] [diff] [review]
Changes uuid.

Changes uuid.


Try push (still running):

https://tbpl.mozilla.org/?tree=Try&rev=9795ca37d8f4
Flags: needinfo?(jviereck.dev)
Comment on attachment 729497 [details] [diff] [review]
Changes uuid.

r=me
Attachment #729497 - Flags: review+
(Assignee)

Updated

4 years ago
status-firefox20: --- → affected
(Assignee)

Comment 4

4 years ago
Try run looks green -> Checkin-Needed flag.

Also requesting dev-docs-needed as the UUID changed and someone pointed out that might be a good thing todo.
Keywords: checkin-needed, dev-doc-needed
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 5

4 years ago
Comment on attachment 729497 [details] [diff] [review]
Changes uuid.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 743252
User impact if declined: Addons might break due to not updated UUID.
Testing completed (on m-c, etc.): Try run, not landed on m-c at point of making approval request
Risk to taking this patch (and alternatives if risky): Very low risk
String or UUID changes made by this patch: nsIPrintSession
Attachment #729497 - Flags: approval-mozilla-beta?
Attachment #729497 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 6

4 years ago
Comment on attachment 729497 [details] [diff] [review]
Changes uuid.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 743252
User impact if declined: Addons might break due to not updated UUID.
Testing completed (on m-c, etc.): Try run, not landed on m-c at point of making approval request
Risk to taking this patch (and alternatives if risky): Very low risk
String or UUID changes made by this patch: nsIPrintSession
Attachment #729497 - Flags: approval-mozilla-release?
Comment on attachment 729497 [details] [diff] [review]
Changes uuid.

This is a mess.

First, I'm pretty sure that this doesn't affect release (but we absolutely wouldn't approve a UUID change there anyway).

Second, we don't change interfaces or UUIDs on beta. So the fact that bug 743252 already landed on beta means we're kinda screwed here either way.

I don't understand why jorgev gave ba= to this in the first place... it seems like the kind of change that should automatically be rejected :-(
Attachment #729497 - Flags: approval-mozilla-release? → approval-mozilla-release-
Attachment #729497 - Attachment is patch: true
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb210464e583
Flags: in-testsuite-
Keywords: checkin-needed
Comment on attachment 729497 [details] [diff] [review]
Changes uuid.

I'm not sure if we'll uplift this yet, but fwiw mozilla-release now have FF20 on it since we did the merge yesterday so resetting the nom flag in case we do take this uplift - we'll build FF20 off of mozilla-release repo which will need this included.
Attachment #729497 - Flags: approval-mozilla-release- → approval-mozilla-release?
After discussing with Benjamin the call is to leave this out of FF20 (and notify certain addon authors we know need to be in the loop on this: F-Secure, Avira, Norton, and Skype).  This is similar to what we did in FF19 with bug 838668.  We should take this to mozilla-aurora right away so we don't run into this on FF21 when it merges to Beta on Monday.
status-firefox20: affected → wontfix
status-firefox22: --- → affected
tracking-firefox22: --- → +
Attachment #729497 - Flags: approval-mozilla-release?
Attachment #729497 - Flags: approval-mozilla-release-
Attachment #729497 - Flags: approval-mozilla-beta?
Attachment #729497 - Flags: approval-mozilla-beta-
Attachment #729497 - Flags: approval-mozilla-aurora?
Attachment #729497 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/bb210464e583
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox22: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
https://hg.mozilla.org/releases/mozilla-aurora/rev/ac5ed16b6a74
status-firefox21: affected → fixed
You need to log in before you can comment on or make changes to this bug.