nsIDOMMozIccManager should have IID revved

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: bajaj, Assigned: psiddh)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Component: DOM → DOM: Device Interfaces
(Reporter)

Updated

6 years ago
Blocks: 851302

Updated

6 years ago
Blocks: 847820
(Reporter)

Updated

6 years ago
Assignee: nobody → echen

Comment 1

6 years ago
Hi :bajaj,

I think the IID issue of IccManager in bug 851302 is caused by former rev.
http://hg.mozilla.org/mozilla-central/rev/7e5295f718b3

In the latest rev, http://hg.mozilla.org/mozilla-central/rev/0f0d01f00f1e, I did modify the IID of IccManager.
Could you help to check the IID issue of IccManager is still there with latest m-c?

If there is any thing I can help, please just let me know.

Thank in advance :)
(Reporter)

Comment 2

6 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #1)
> Hi :bajaj,
> 
> I think the IID issue of IccManager in bug 851302 is caused by former rev.
> http://hg.mozilla.org/mozilla-central/rev/7e5295f718b3
> 
> In the latest rev, http://hg.mozilla.org/mozilla-central/rev/0f0d01f00f1e, I
> did modify the IID of IccManager.
> Could you help to check the IID issue of IccManager is still there with
> latest m-c?
> 
> If there is any thing I can help, please just let me know.
> 
> Thank in advance :)

Thanks for looking into this :) I am going to needsinfo folks involved with "http://hg.mozilla.org/mozilla-central/rev/0f0d01f00f1e" to check on this
(Reporter)

Comment 3

6 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #1)
> Hi :bajaj,
> 
> I think the IID issue of IccManager in bug 851302 is caused by former rev.
> http://hg.mozilla.org/mozilla-central/rev/7e5295f718b3

:mounir, Edgar suggest's that the above changeset would have caused the missing IID rev, can you please check if that's the case and get the needed change ready ? Thanks !

> In the latest rev, http://hg.mozilla.org/mozilla-central/rev/0f0d01f00f1e, I
> did modify the IID of IccManager.
> Could you help to check the IID issue of IccManager is still there with
> latest m-c?
> 
> If there is any thing I can help, please just let me know.
> 
> Thank in advance :)
(Reporter)

Updated

6 years ago
Flags: needinfo?(mounir)
Indeed, the iid wasn't changed with bug 840780 but given that this is a B2G interface I wouldn't worry much about it. However, assigning the bug to Siddartha in case of he can do something about it.
Assignee: echen → psiddh
Blocks: 840780
No longer blocks: 847820
Flags: needinfo?(mounir)
OS: Mac OS X → All
Hardware: x86 → All
Hi, Mounir
Can you suggest how to fix this?
Since the newer version of IccManager has been check-in already.
(In reply to Yoshi Huang[:allstars.chh][:yoshi] from comment #5)
> Hi, Mounir
> Can you suggest how to fix this?
> Since the newer version of IccManager has been check-in already.

Indeed, there is nothing to do in mozilla-central, the fix would consist in changing the uuid in mozilla-aurora https://hg.mozilla.org/releases/mozilla-aurora/
(In reply to Mounir Lamouri (:mounir) from comment #6)
Hi, Mounir
In Aurora, Bug 840780 hasn't been checked in yet.

Do you mean we need to create another patch of Bug 840780 for Aurora?
In that case, Bug 847820 is landed after Bug 840780, should we also create another patch of Bug 847820 for Aurora?
And how do we prevent those original patches(no revID changed) in both bugs who are already landed in m-c to land in m-a? 

Or in this bug we provide a patch for rev ID changed only,
but how do we make sure this patch could be check-in between Bug 840780 and Bug 847820 on m-a?

thanks
The required patch is a one-liner (just changing the iid) but given that aurora is now uplifted to mozilla-beta, if this lands, it needs to be in m-b, not m-a.

Comment 9

6 years ago
Given that by rule we don't rev IIDs after the first beta, we either need to do this immediately for FF20 or not at all. I don't think it matters in this case because binary extensions are not going to use this interface. So I'm going to take the liberty of marking this WONTFIX and letting you guys work on more important things.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.