Last Comment Bug 853097 - cfi_frame-info.cc won't compile with VS2008SP1/VC9 after bug 779291
: cfi_frame-info.cc won't compile with VS2008SP1/VC9 after bug 779291
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Gecko Profiler (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla22
Assigned To: Kent James (:rkent)
:
:
Mentors:
Depends on:
Blocks: 779291
  Show dependency treegraph
 
Reported: 2013-03-20 12:17 PDT by Kent James (:rkent)
Modified: 2013-03-27 14:14 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add StandardInteger.h (871 bytes, patch)
2013-03-20 12:19 PDT, Kent James (:rkent)
no flags Details | Diff | Splinter Review
This also works (1.09 KB, patch)
2013-03-26 13:55 PDT, Kent James (:rkent)
ted: review+
Details | Diff | Splinter Review

Description Kent James (:rkent) 2013-03-20 12:17:01 PDT
When I do a clobber build of Thunderbird, I'm getting a failure in mozilla core code that looks like this:

c:\tb\1-central\src\mozilla\config\rules.mk:1056:0$ c:/tb/1-central/tb-pydebug/mozilla/_virtualenv/Scripts/python.exe -O
 c:/tb/1-central/src/mozilla/build/cl.py cl -Focfi_frame_info.obj -c -D_HAS_EXCEPTIONS=0 -I../../../../../dist/stl_wrapp
ers  -DMOZ_THUNDERBIRD=1 -DNO_NSPR_10_SUPPORT -Ic:/tb/1-central/src/mozilla/toolkit/crashreporter/google-breakpad/src/pr
ocessor/../.. -Ic:/tb/1-central/src/mozilla/toolkit/crashreporter/google-breakpad/src/processor/.. -Ic:/tb/1-central/src
/mozilla/toolkit/crashreporter/google-breakpad/src/processor -I. -I../../../../../dist/include  -Ic:/tb/1-central/tb-pyd
ebug/mozilla/dist/include/nspr -Ic:/tb/1-central/tb-pydebug/mozilla/dist/include/nss        -wd4099 -TP -nologo -W3 -Gy
-Fdgenerated.pdb -wd4251 -wd4345 -wd4351 -wd4482 -wd4800 -wd4819 -we4553 -GR-  -DDEBUG -D_DEBUG -DTRACING -Zi -Oy- -MDd
          -FI ../../../../../dist/include/mozilla-config.h -DMOZILLA_CLIENT  c:/tb/1-central/src/mozilla/toolkit/crashre
porter/google-breakpad/src/processor/cfi_frame_info.cc
cfi_frame_info.cc
c:\tb\1-central\src\mozilla\toolkit\crashreporter\google-breakpad\src\processor/postfix_evaluator-inl.h(319) : error C20
65: 'int64_t' : undeclared identifier

There are additional errors associated with other types.
Comment 1 Kent James (:rkent) 2013-03-20 12:19:58 PDT
Created attachment 727313 [details] [diff] [review]
Add StandardInteger.h

This patch allows the compile to continue. I'm not asking for a review though because I don't really understand why this is needed, so I must be missing something.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2013-03-22 07:47:02 PDT
This was supposed to be fixed by:
http://mxr.mozilla.org/mozilla-central/source/configure.in#6031
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/google-breakpad/src/google_breakpad/common/breakpad_types.h

Are you building with --disable-crashreporter?
Comment 3 Kent James (:rkent) 2013-03-25 17:45:30 PDT
"Are you building with --disable-crashreporter?"

Yes I believe that I am - because of some previous compile issue that is probably long gone.
Comment 4 Ted Mielczarek [:ted.mielczarek] 2013-03-25 17:49:15 PDT
Ok, we probably just need to move this AC_DEFINE_UNQUOTED:
http://mxr.mozilla.org/mozilla-central/source/configure.in#6041

outside of the 'if test -n "$MOZ_CRASHREPORTER";' block. Can you test that? You can just move it down to immediately after that whole if block.
Comment 5 Kent James (:rkent) 2013-03-26 13:55:15 PDT
Created attachment 729783 [details] [diff] [review]
This also works

This patch, which is my interpretation of comment 4, also allows me to successfully compile.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2013-03-26 15:41:22 PDT
Comment on attachment 729783 [details] [diff] [review]
This also works

Looks fine.
Comment 7 Ryan VanderMeulen [:RyanVM] 2013-03-27 07:54:33 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1562dc5d65c8
Comment 8 Ryan VanderMeulen [:RyanVM] 2013-03-27 14:14:37 PDT
https://hg.mozilla.org/mozilla-central/rev/1562dc5d65c8

Note You need to log in before you can comment on or make changes to this bug.