Open Bug 853422 Opened 10 years ago Updated 5 years ago

File menu should be more consistent for private sessions (permanent & not)

Categories

(Firefox :: Private Browsing, enhancement)

enhancement
Not set
normal

Tracking

()

Tracking Status
firefox20 - ---
firefox21 - ---
firefox22 - ---

People

(Reporter: ioana_damy, Unassigned)

Details

(Keywords: uiwanted)

Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

STR:
1. Launch Firefox.
2. Open a private window.
3. Observe the following menus both for the regular window and the private one:
*File menu,
*contextual menu opened by right-clicking a link.
4. Enter permanent PB mode and open the menus above again.

Expected Results:
Options for regular window: New Tab, New Window, New Private Window.
Options for private window: New Private Tab, New Window, New Private Window.
Options for window in permanent PB mode: New Tab, New Window (considering the user should remember he chose permanent PB) OR New Private Tab, New Private Window.

Actual Results:
The menu options for the PB session look confusing for all cases.
Version: 20 Branch → Trunk
I'm nominating this for tracking on both beta, aurora, and nightly for user experience reasons. I'm assuming this also happens in from the user agent in comment #0.
This is by design.  You don't get to have non-priavate windows/tabs in permanent PB mode.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → INVALID
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> This is by design.  You don't get to have non-priavate windows/tabs in
> permanent PB mode.

This bug was filed as an enhancement request, not a regular bug, because it was by design.

The request is not about being or not being able to open certain kinds of tabs, but the text for the options for opening them.

Please read comment 0 and take into consideration 
- there are plenty of users that are not that experienced with everything the browser offers and they can get easily confused by the current options labels/text;
- more advanced users will find the text/labels not consistent (as I and others did).
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → NEW
Not tracking an enhancement request.
(In reply to comment #3)
> (In reply to :Ehsan Akhgari (needinfo? me!) from comment #2)
> > This is by design.  You don't get to have non-priavate windows/tabs in
> > permanent PB mode.
> 
> This bug was filed as an enhancement request, not a regular bug, because it was
> by design.
> 
> The request is not about being or not being able to open certain kinds of tabs,
> but the text for the options for opening them.
> 
> Please read comment 0 and take into consideration 
> - there are plenty of users that are not that experienced with everything the
> browser offers and they can get easily confused by the current options
> labels/text;
> - more advanced users will find the text/labels not consistent (as I and others
> did).

Do you have a proposal for what you want to see here?
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #5)
> Do you have a proposal for what you want to see here?

My proposal is described in comment 0 - Expected Results.
So basically just rename New Tab to New Private tab in private windows?  Doing that makes sense to me, I think.  Stephen, what do you think?
Flags: needinfo?(shorlander)
Keywords: uiwanted
(In reply to :Ehsan Akhgari (needinfo? me!) from comment #7)
> So basically just rename New Tab to New Private tab in private windows? 
> Doing that makes sense to me, I think.  Stephen, what do you think?

Makes sense to me, adds clarity.
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.