Hebrew is backwards in some option lists

RESOLVED DUPLICATE of bug 82849

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 82849
17 years ago
9 years ago

People

(Reporter: Sagie Maoz, Assigned: mkaply)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Some option lists (<SELECT>) in some pages written in Visual Hebrew still has
the hebrew written backwards.
In the page at http://www2.iol.co.il/tv/index.html the "From" list has Hebrew
text as the selected option, and the text is written backwards. This is weird,
because in the same page, another list with hebrew text, but those are normal
(perhaps because they're created via javascript?).

Also, I do not understand why the page keeps refreshing in Mozilla.
Marking this as a duplicate of bug 82849

The repeated page refreshing should be opened as a separate bug. I'm not a
javascript expert, but this function looks very suspicious to me: 

function UpdateBoxManyT(types,form_name)
{
  var box = document.forms[form_name].elements['Channel'];
  box.options.length = 0;
  for (var t = 0; t < types.length; t++)
    if (types[t].selected)
      for (var j = 0; j < optArrT[types[t].value].length; j++)
        box.options[box.options.length] = optArrT[types[t].value][j];
  if (navigator.userAgent.indexOf('MSIE') == -1)
    history.go(0);
}


*** This bug has been marked as a duplicate of 82849 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: giladehven → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.