Last Comment Bug 853626 - Firefox hangs when accessing battlelog.battlefield.com due to slow Font Loading
: Firefox hangs when accessing battlelog.battlefield.com due to slow Font Loading
Status: RESOLVED WORKSFORME
: perf
Product: Core
Classification: Components
Component: Graphics: Text (show other bugs)
: 19 Branch
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
http://youtu.be/xbcc2SVEZ7Q
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-21 13:49 PDT by krypt0n
Modified: 2015-09-19 17:29 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description krypt0n 2013-03-21 13:49:44 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Tried to access the website http://battlelog.battlefield.com


Actual results:

Firefox hangs/freezes for a certain amount of time depending on system load and system specs.


Expected results:

Firefox should have loaded the page without freezing.
Comment 1 krypt0n 2013-03-21 13:53:29 PDT
Creating a new profile does not remove the issue as a previous bugreport suggests https://bugzilla.mozilla.org/show_bug.cgi?id=764550

I can also reproduce this on several other computers running Windows 7 operating system. Battlelog's website isn't the only one that causes Firefox to freeze/hang when accessing the website for the first time after Firefox has been opened. Opening any website that causes Firefox to freeze/hang removes the freezing/hanging from websites that would otherwise cause Firefox to freeze/hang when accessing the website for the first time after opening Firefox.
Comment 2 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-22 07:56:56 PDT
That Site redirects to http://battlelog.battlefield.com/bf3/gate correct?
Is your Issue happening on that Site (pre Login) or only after Login?
Comment 3 krypt0n 2013-03-22 11:10:58 PDT
Correct on the URL.

Issue appears directly when trying to access the URL (only the site title is shown). The slower the computer, the longer FF hangs.

By Firefox hanging, I mean that Firefox becomes unresponsive. On faster computers, you have to look at the little loading circle. When it stops spinning, firefox isn't responding and is "hanging". I'm trying the 20 beta and it loads the site even faster than 19, but it still hangs. Internet Explorer and Chrome load the site correctly and I don't think Firefox should hang or freeze at all when loading websites, even if it's just for 0.2-0.4 seconds.
Comment 4 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-22 19:21:25 PDT
Maybe, I see no Issue though ;-)

If I have to guess this maybe due to the CSS Styles (animation and transform with set opacity) on the "device-mobile" and "device-computer" DIVs.
Comment 5 krypt0n 2013-03-23 11:48:17 PDT
So it's ok for Firefox to hang and freeze without a reason while loading certain websites while the competition can load those pages without freezing or hanging? I guess there's a reason why Firefox is losing users...

After some brief testing, it appears the freezing/hanging bug starts somewhere after version 15.0.1. I had v15 in Virtual XP and it worked fine. It automatically updated itself to 19.0.2 after closing and starting Firefox and the bug was present. I downgraded FF to 15.0.1 and it worked fine again.
Comment 6 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-23 13:32:31 PDT
I won't comment on the non-technical Stuff, but if you want to help further you can try to find a Regression Range:

https://github.com/mozilla/mozregression/
+ Startdate 2012-06-05 (Fx 15 moved to Aurora)
Comment 7 krypt0n 2013-03-25 14:51:57 PDT
Ran it untill I got the same results every time.

Last good nightly: 2011-01-21
First bad nightly: 2011-01-22

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8d52e3b68ca6&tochange=7b396ca54953

After that version, Firefox becomes noticeably slower loading the battlelog-website. Even the latest Firefox version is really fast if I disable the .css (eg. by blocking it with AdBlock).

My non-technical answer was for your non-technical remark about this not being an issue.
Comment 8 krypt0n 2013-03-25 15:13:43 PDT
I must emphasise that this is when accessing the website for the first time after Firefox has been opened. This usually doesn't happen when other websites have been accessed.
Comment 9 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-25 18:09:15 PDT
Well, your found Range

(In reply to krypt0n from comment #7)
> Last good nightly: 2011-01-21
> First bad nightly: 2011-01-22

contradicts with

(In reply to krypt0n from comment #5)
> After some brief testing, it appears the freezing/hanging bug starts
> somewhere after version 15.0.1. I had v15 in Virtual XP and it worked fine.

Do you only see this in VMs?
Do the Computers you see this with have a common GPU?
Does the Issue persists if you disable GPU Acceleration/use Firefox' Safe-mode (what actually disables GPU Accel.)?

Btw, I wrote that *I* see no Issue (on my End), not there isn't any Issue at all, ok?
Comment 10 krypt0n 2013-03-25 23:28:00 PDT
I did the mozregression test in Windows 7 x64, not inside a VM.

I can reproduce and see the issue with all computers that run a Windows OS (Firefox in eg. Ubuntu is not affected by this). Doesn't matter if it's inside a VM or not. Guessing XP has a different range OR something else messed up the results there. I'll do mozregression test in XP VM and a few laptops running Vista/XP/Win7/Win8 see if I get diff. results or results that are reliable.

Issue persists if I disable GPU accel. (Use Hardware Acceleration when available) or use safe mode.

Define common GPU. Laptops have integrated GPUs (Intel/nVidia), desktop has a regular non-integrated PCI-e GPU (nVidia GTX 5xx -series).

(In reply to XtC4UaLL [:xtc4uall] from comment #9)
> Btw, I wrote that *I* see no Issue (on my End), not there isn't any Issue at
> all, ok?
The correct way to say that is "I can't reproduce this". Less text and no chance of misinterpretation.
Comment 11 krypt0n 2013-03-26 03:15:40 PDT
It seems that VM is too unreliable to do any testing (too many random results). Needs to be done in native OS. I also can't seem to reproduce this in native XP after all... at least not reliably (Earlier experience was with VM). FF in native XP certainly loads these sites faster than in native Vista/7/8, even when using "ancient" hardware.

I also realized that it would be smarter to try to reproduce the issue with a local copy of the site, instead of relying on opening the site from the web for each test. Gives the same results at least so downloading speed won't be a variable.

I can reproduce this in Vista x86, 7 x86 & x64 and 8 x64. Noticed on a Zenbook with Win 8 x64 (uses SSD) that after 2011-01-21 FF does a sort of double loading of the website, first it stops and loads the title, then it stops and loads the contents. 2011-01-20 stops and loads the title and page at the same time. Compared to Chrome which remains responsive while loading, Firefox's way of stopping to load the site for even a short while seems strange, but at least it's consistent with older Firefox versions :-/

Just guessing here, but maybe this wouldn't be an issue if Firefox used separate processes for it's tabs? Opera suffers from this same issue together with Firefox and it's also relying on a single process for everything. Opera however seems to handle tabs better, as the whole browser doesn't stop responding when a single tab is hanging.
Comment 12 Mitza 2013-03-27 08:30:46 PDT
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

I was not able to reproduce this issue with FF 19.0.2 (Build id: 20130307023931)when loading http://battlelog.battlefield.com .
Comment 13 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-27 18:02:56 PDT
Hmm, try this:
* open about:config
* search for gfx.downloadable_fonts.enabled
* set it to false by double-click/toggle
* clear your Cache
* restart Firefox and check if Loading the Site is any faster

Maybe it's about the WOFF Font downloaded per

@font-face {
    font-family: 'BebasNeueRegular';
    src: url('../../base/fonts/BebasNeue-webfont.eot');
    src: local('☺'),
        url('../../base/fonts/BebasNeue-webfont.woff') format('woff'),
        url('../../base/fonts/BebasNeue-webfont.ttf') format('truetype'),
        url('../../base/fonts/BebasNeue-webfont.svg#webfontE057xtoO') format('svg');
    font-weight: normal;
    font-style: normal;

Else of this, a Dump of the Web Console's 'Net Tab' Output (via CTRL + Shift + K) and its Timeline would help further ...
Comment 14 krypt0n 2013-03-28 00:00:20 PDT
Disabling gfx.downloadable_fonts.enabled fixes this issue.
Comment 15 (mostly gone) XtC4UaLL [:xtc4uall] 2013-03-28 08:31:55 PDT
Ok, thanks.

Moving for further Investigation. Can this somehow be mitigated?
Comment 16 krypt0n 2013-03-29 03:55:02 PDT
(In reply to XtC4UaLL [:xtc4uall] from comment #15)
> Moving for further Investigation. Can this somehow be mitigated?

Mitigated?
Comment 17 Wayne Mery (:wsmwk, NI for questions) 2015-09-19 09:56:17 PDT
Still see this?

I see no difference between current version of chrome and current nightly
Comment 18 Wayne Mery (:wsmwk, NI for questions) 2015-09-19 09:58:05 PDT
 krypt0n Still see this?
Comment 19 krypt0n 2015-09-19 12:25:13 PDT
Nope. Seems to have been fixed along the years. Open another ticket if you have issues.

Note You need to log in before you can comment on or make changes to this bug.