Spell checker in browser forgets language setting

RESOLVED FIXED in mozilla43

Status

()

RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: 3.14, Unassigned)

Tracking

(Blocks: 1 bug)

unspecified
mozilla43
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

6 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0 SeaMonkey/2.16.2

Until recently I would select a language for web form checking and SeaMonkey would remember the setting until changed. Now it keeps switching to English, so for every German text I have to switch again and again.

pi

Updated

4 years ago
Blocks: 1073827

Comment 1

4 years ago
Switching when exactly?
- when you revisit the page?
- when you defocus and refocus the browser tab?
- when you defocus and refocus the input element?
- randomly while the focus is remaining on the input element?

Updated

4 years ago
Depends on: 959785
(Reporter)

Comment 2

4 years ago
I mean:
1) I fill out any web form text field and switch to language to German or English (the only two I use)
2) Later I fill another web form (other site) and find the language is not the one I have chosen last.

Comment 3

4 years ago
So it's changing when you go and fill in another web form on another website.  This might be down to the lang attribute or Content-Language header.  If this is the case, then it's really down to bug 1073840.  Can you give example URLs of sites on which you are having the problem?
(Reporter)

Comment 4

4 years ago
I don't know how to reproduce it. But I have now seen it with Twitter. I had written in German and adjusted the spellcheck to that. Next time I was typing, it was again set to English.

Comment 5

4 years ago
Hmm.  So it isn't clear whether this is a duplicate of another bug.  According to my experiments, Twitter sets the lang attribute of the whole page based on the UI language set in your user preferences.  So my guess is that it's the combination of bug 959785 or one of its other dependent bugs and bug 1073840.
Whiteboard: DUPEME

Updated

3 years ago
Depends on: 1200533

Comment 6

3 years ago
Closing this bug as per bug 1073827, comment #33.
If you want to reopen it, please present a reproducible test case.

I realise that this bug was reported using SeaMonkey. However, it was reported against product=core and component="spell checker" and this has been fixed. If there is a remaining problem in SeaMonkey, please raise a specific bug for SeaMonkey.

Note that SeaMonkey displays the value of "spellchecker.dictionary" in the user interface
(Edit > Preferences > Appearance > Spelling).

Also please note that SeaMonkey, like Thunderbird, has decoupled the language in an e-mail composition from this preference, see bug 1163395.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
You need to log in before you can comment on or make changes to this bug.