[CALL LOG] Calls are not appearing in the call log

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: carlosmartinez, Assigned: etienne)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest
Bug Flags:
in-moztrap -

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.1 verified)

Details

Attachments

(1 attachment)

Tested in unagi device with latest commit from master branch 12174ec

STR:
1-Place an outgoing call
2-Receive a miss call

Expected result --> You should see two entries in the call log

Actual result --> Nothing is shown. Neither after kill the dialer app and open it again.
In fact the problem is related to the LazyL10n which is not ready for the loading of the "l10n.js" library using other means (such as the LazyLoader object). This is done now at https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/js/newsletter_manager.js#L38 and this causes the "localized" event not to be notified and consequently the LazyL10n.get never invokes the callback.
Assignee: nobody → etienne
(Assignee)

Comment 2

6 years ago
Mmmh.. looks like it may in fact be caused by the fact that the dialer now needs the "idle" permission, so people who update gaia without doing a reset end up in a weird state.

Anyway the newsletter_manager shouldn't load l10n before the idle timer triggers, so I'm writing a quick patch to fix that *and* ensure that dogfooders won't see their call log break because of the newsletter manager.
(Assignee)

Comment 3

6 years ago
Created attachment 729036 [details]
Pointer to github's PR
Attachment #729036 - Flags: review?(gtorodelvalle)
(In reply to Etienne Segonzac (:etienne) from comment #2)
> Mmmh.. looks like it may in fact be caused by the fact that the dialer now
> needs the "idle" permission, so people who update gaia without doing a reset
> end up in a weird state.
> 
> Anyway the newsletter_manager shouldn't load l10n before the idle timer
> triggers, so I'm writing a quick patch to fix that *and* ensure that
> dogfooders won't see their call log break because of the newsletter manager.

As far as I can tell I have the issue (gaia master from this week-end) also AFTER reset-gaia.
Comment on attachment 729036 [details]
Pointer to github's PR

Hi! Definitely a much safer implementation, at least regarding the lazy loading of the L10n capabilities in the Comms app :-)
Attachment #729036 - Flags: review?(gtorodelvalle) → review+
It does not affect v1.0.1 yet, but it will do so as soon as bug 824930 is uplifted to v1.0.1 (which is a tef+ bug), so marking it as tef+ to be uplifted as the same time bug 824930.
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
(Assignee)

Comment 7

6 years ago
https://github.com/mozilla-b2g/gaia/commit/98df87a28b336b44148a54867e02b171e9a481e3
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Keywords: smoketest
v1-train: 8e62762317858f393ea07a28712505c7b2199298

This did not apply cleanly to v1.0.1.  Looks like a fairly simple merge conflict, but I'd prefer the patch author to resolve it. You might be able to do it with:

  cd gaia
  git checkout v1.0.1
  git cherry-pick 8e62762317858f393ea07a28712505c7b2199298
  <RESOLVE MERGE CONFLICT>
  git commit
status-b2g18: affected → fixed
I can confirm it works on my Nexus S, gaia updated this morning \o/
Probably gave errors because bug 824930 was not applied to v1.0.1 yet, and this patch is applied to the code added in there.
We should wait till that one lands, and try again this one.
done in https://github.com/mozilla-b2g/gaia/commit/0c6d68e17e2a3d5c7ee8575f4b698808e25bfffa but I'd like someone to revise it in case I did something wrong
(Assignee)

Comment 12

6 years ago
(In reply to Fernando Campo (:fcampo) from comment #11)
> done in
> https://github.com/mozilla-b2g/gaia/commit/
> 0c6d68e17e2a3d5c7ee8575f4b698808e25bfffa but I'd like someone to revise it
> in case I did something wrong

Looking good :)
status-b2g18-v1.0.1: --- → fixed

Comment 13

6 years ago
Does not reproduce on:
Unagi Mozilla RIL Build ID: 20130327070202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/879324d41588
Gaia: e7e7c1a473b4069544f2dad779b1c9b1bab91663

Updated

6 years ago
Flags: in-moztrap?
QA Contact: dwatson

Comment 14

6 years ago
There are already tests case in Moztarp that cover this issue.
https://moztrap.mozilla.org/manage/cases/?filter-id=2222
Flags: in-moztrap? → in-moztrap-

Comment 15

6 years ago
Issue no longer reproduces on Unagi device.
Build ID: 20130329070203
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/56c922308fd1
Gaia: 0a9f78bffafda93a159c1f502e8b110c2f49a500

Also issue appears fixed on build id: 20130328121142
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/53b5324732da
Gaia: d3bf49f961e59d7d92b73e0aa317e183572fb546

Both outgoing call and missed call are shown in the call log.
Verified as fixed
Status: RESOLVED → VERIFIED
status-b2g18: fixed → verified
status-b2g18-v1.0.1: fixed → verified
You need to log in before you can comment on or make changes to this bug.