If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The back button is transparent on active

RESOLVED FIXED in Firefox 22

Status

()

Firefox for Android
Theme and Visual Design
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: Daniel, Assigned: sriram)

Tracking

({regression})

22 Branch
Firefox 22
ARM
Android
regression
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 729074 [details]
Screenshot of transparent button

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130324 Firefox/22.0
Build ID: 20130324031024

Steps to reproduce:

Press the back button.

Using a 22.0a1 build from 2013-03-24


Actual results:

One can see through the button (see screenshot).


Expected results:

There should be a solid color behind the button.
Which Android device is that?
Created attachment 729118 [details]
Nightly (03/25) - Screenshot

Ok I can reproduce too, this is an Alcatel One Touch Evo 7" Phablet, and reproducible holding down the back button.

Updated

5 years ago
Assignee: nobody → sriram
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Duplicate of this bug: 854495

Updated

5 years ago
Keywords: regression
(Assignee)

Comment 4

5 years ago
Created attachment 729647 [details] [diff] [review]
Patch

This uses the same approach as the tabs button. The combined colors are specified for normal and private modes. They are added to the LWTheme state list too.
Attachment #729647 - Flags: review?(mark.finkle)
Attachment #729647 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/31778c6de93b
https://hg.mozilla.org/mozilla-central/rev/31778c6de93b
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
You need to log in before you can comment on or make changes to this bug.