Closed Bug 854619 Opened 12 years ago Closed 12 years ago

Purchase with carrier billing fails with a 400 if the Price is '0,99'

Categories

(Marketplace Graveyard :: Payments/Refunds, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED
2013-04-04

People

(Reporter: krupa.mozbugs, Assigned: keir)

References

Details

(Whiteboard: p=)

Attachments

(1 file)

Attached file log file
Tester is already logged into marketplace

steps to reproduce:
1. Set the Language on your unagi phone = Spanish
2. Start the purchase flow for a paid app on your unagi phone
3. Enter your PIN
4. Confirm your mobile number and enter the bango PIN
5. In the Confirm your purchase screen, click on the Buy button


expected behavior:
purchase is successful

observed behavior:
purchase fails with a 400 error when language = Spanish (region is still US)

NOTE: purchase was successful when language on the phone was set to English.
Priority: -- → P1
The Price we get back in the query string is '0,99' so the fix is to handle that in Solitude. The trail that led me there...


The URL returning 400 is in WebPay:
marketplace-dev.allizom.org/mozpay/bango/success?ResponseCode=OK&ResponseMessage=Success&BangoUserId=1530856215&MerchantTransactionId=webpay%3adad359ad-dfc3-40ec-9dfe-eecf1c840d10&BangoTransactionId=1078709655&TransactionMethods=USA_ATT%2cAT%26T+USA%2cTESTPAY%2cTest+Pay&BillingConfigurationId=226510&MozSignature=b503193f82131f260380c9d621d909aaf9824808ffe6e2f47cd85c5abb079304&Currency=USD&Network=USA_ATT&Price=0%2c99&P=

I reproduced it today on dev and here is the Solitude error:

Mar 27 10:22:25 dev1.addons.phx1.mozilla.com: [None] w.bango:INFO Bango payment notice for transaction uuid u'webpay:1b9b5d85-0bb3-442f-8532-fba6adda177d' failed: Client Error 400: https://payments-dev.allizom.org/bango/notification/#012Content: {"amount": ["Enter a number."]

This is what happened in Solitude:

Mar 27 10:22:11 dev2.addons.phx1.mozilla.com: [] s:INFO GET /generic/transaction/?uuid=webpay%3A1b9b5d85-0bb3-442f-8532-fba6adda177d :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:252
Mar 27 10:22:25 dev1.addons.phx1.mozilla.com: [] s:INFO POST /bango/notification/ :/data/www/payments-dev.allizom.org/solitude/solitude/base.py:252
Mar 27 10:22:25 dev1.addons.phx1.mozilla.com: [None] s.bango:INFO Received notification for billing_config_id '227240': bango_response_code: 'OK'; bango_response_message: 'Success'; bango_trans_id: '1078711865' :/data/www/payments-dev.allizom.org/solitude/lib/bango/resources/notification.py:35
Mar 27 10:22:25 dev1.addons.phx1.mozilla.com: [None] s.bango:INFO Notification invalid: 227240 :/data/www/payments-dev.allizom.org/solitude/lib/bango/resources/notification.py:38
Summary: Purchase with carrier billing fails with a 400 if language on the phone is set to Spanish → Purchase with carrier billing fails with a 400 if the Price is '0,99'
Keir, Tom, why is Price localized? What other formats will we see prices arrive in?
Also, we would need a locale in the query string if prices are always going to be localized. Otherwise, we have to take a shot in the dark about how to parse the number.
Target Milestone: 2013-03-28 → 2013-04-04
Fixed on test.
Is this only fixed for Spanish or all locales? I could not verify it because when I got to the Confirm Your Number screen the Bango code was never texted to me. I tried several times. Any ideas?
(In reply to Kumar McMillan [:kumar] from comment #5)
> Is this only fixed for Spanish or all locales? I could not verify it because
> when I got to the Confirm Your Number screen the Bango code was never texted
> to me. I tried several times. Any ideas?

All locales. 11 SMS sent on the test system to cell numbers ending in 3214 or 6239 yesterday - all sent OK.  Did the device have signal etc?
Great, thanks. I tried again today and I received the SMS code fine (my number ends in 2397). I also confirmed that the price was fixed in the Spanish locale. The purchase completed successfully.
Assignee: nobody → keir
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Verified as fixed based on comment #7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: