Closed Bug 85477 Opened 19 years ago Closed 19 years ago

Browser doesn't start up helper app

Categories

(Core Graveyard :: Viewer App, defect)

Sun
Solaris
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: peter.oshea, Assigned: rickg)

Details

Browser won't start up helper app (acrobat) for downloaded file.  Under
prefs...navigator...helper applications  I've got application/acrobat and
application/pdf both set up to start acrobat with the command "acrobat %s", like
it was in Navigator.

When I click on a link to a pdf file, the file downloads, but no acrobat starts
up.  The output to the terminal states that the file was downloaded successfully.

Running on Solaris 2.8.
Seems mozilla doesn't read your $PATH but wants full path to helper application.
Since you only have "acrobat %s" in the helper command: Marking dup of bug 56662

*** This bug has been marked as a duplicate of 56662 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
I don't agree that this is a duplicate.

If I put the whole path (/cad/apps/util/bin/acroread %s) into the 
mime type, it _still_ doesn't start up acroread.  No error messages output
to the terminal either.
Reopening. Can you try without the additional %s please, and tell if that
changed anything.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Aha!

Taking out the %s makes it work.  Yet another difference between Mozilla and
Navigator.

You know, I could swear I tried taking out the %s a while ago, and it still
didn't work.  But I probably wasn't putting in the absolute path to the app
then, as I am now.

Peter, is there still a bug here?  Would you mind if I close it as WFM?
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
Yes, please close out the bug.  Thanks.
Pasting this from bug 121137 (note to bug#85477) which I have resolved as INVALID:

I too have not been able to get helper apps to work.

I too have tried to run adobe acrobat reader. And real player too.

I give the whole path to the executable but when a link is clicked the 'save as'
dialog comes up.

Netscape 6.1EA is being served read only from a Solaris 8 system
I've also loaded Mozilla (Build ID 2002011510) and I'm seeing the same issues.

Can someone please tell me what's going on!
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.