Linked contacts without name but with e-mail are rendered wrong

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: crdlc, Assigned: crdlc)

Tracking

({regression})

unspecified
x86
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

188 bytes, text/html
Jose Manuel Cantera
: review+
Details
(Assignee)

Description

5 years ago
STR:

1) I have a contact with just email and photo defined (kevin@yahoo.es)
2) I gonna link this one to my friend "Kevin Maicon" in Facebook
3) The first time, the contact is displayed correctly on the list showing "Kevin Maicon" and his picture
4) Close the contacts app
5) Open the contacts app
6) You can view the contact item with the name "kevin@yahoo.es kevin@yahoo.es". The name will be the email duplicated
(Assignee)

Comment 1

5 years ago
It is reproducible on v1.0.1, v1-train and master
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Keywords: regression
(Assignee)

Comment 2

5 years ago
Created attachment 729593 [details]
Patch v1
Attachment #729593 - Flags: review?(jmcf)

Comment 3

5 years ago
After landing bug 852036, this patch will also need to be tef+, as otherwise linked contacts could not be searchable and even they could wrongly placed on the build, so nominating it. I can clarify more if needed
blocking-b2g: --- → tef?

Comment 4

5 years ago
(In reply to Jose M. Cantera from comment #3)
> After landing bug 852036, this patch will also need to be tef+, as otherwise
> linked contacts could not be searchable and even they could wrongly placed
> on the build, so nominating it. I can clarify more if needed

erratum

After landing bug 852036, this patch will also need to be tef+, as otherwise
linked contacts could not be searchable and even they could wrongly be placed
on the list, so nominating it. I can clarify more if needed
(Assignee)

Updated

5 years ago
Duplicate of this bug: 855353
based on screenshots in bug 855353 I think we need to block
blocking-b2g: tef? → tef+
(Assignee)

Comment 7

5 years ago
I have to support updates on given and family names on FB, after that maybe we could land this one

Updated

5 years ago
status-b2g18: --- → affected
status-b2g18-v1.0.1: --- → affected

Updated

5 years ago
Attachment #729593 - Flags: review?(jmcf) → review+

Comment 8

5 years ago
https://github.com/mozilla-b2g/gaia/commit/4978fc82b2877394af5bc43a377cfafff99b4e06
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Flags: in-moztrap?(crdlc)
I was not able to uplift this bug to v1-train and v1.0.1.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1-train and v1.0.1, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1-train
  git cherry-pick -x -m1 4978fc82b2877394af5bc43a377cfafff99b4e06
  <RESOLVE MERGE CONFLICTS>
  git commit
  git checkout v1.0.1
  git cherry-pick -x $(git log -n1 v1-train)

Comment 12

5 years ago
issue is NOT reproducible on both V1.0.1 and V1.1.0
- Name field was not the duplicated by auto populated email address in the first name field.  

tested on Unagi running the following builds:
V1.0.1
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ccec751a468e
Gaia   ee0bef61c0a25c806dd1eec5a4e047bc418a5f73
Build  2013-04-02-070202

V1.1.0
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/68c8a883cfc0
Gaia   1c38c91bb16f2bf0d5066c4787d2249463f61bb3
Build  2013-04-02-070204Maps 

Photo is populated with the photo created on the device side. First name and all other fields are populated with the facebook information that has been linked.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

5 years ago
Flags: in-moztrap?(crdlc)
You need to log in before you can comment on or make changes to this bug.