Closed Bug 854980 Opened 7 years ago Closed 6 years ago

Rewrite tabs without use of traits

Categories

(Add-on SDK Graveyard :: General, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 854982

People

(Reporter: irakli, Assigned: irakli)

References

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → rFobic
Comment on attachment 729879 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/903

First three commits are just a foundation but there are no reasons why we could not land them as is. That way overall patch can be reduced to a smaller size.
Attachment #729879 - Flags: review?(evold)
Priority: -- → P1
Attachment #729879 - Flags: review?(evold) → review?(dtownsend+bugmail)
Commit pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/e5fd0a076823e654901120fae592cee8b2786321
Merge pull request #903 from Gozala/bug/tab-detraitifaction@854980

Bug 854980 - Implementing simple utils for observing window / tab events r=@Mossop
Comment on attachment 729879 [details]
Pointer to Github pull request: https://github.com/mozilla/addon-sdk/pull/903

Forgot to mark this
Attachment #729879 - Flags: review?(dtownsend+bugmail) → review+
Commit pushed to integration at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/e5fd0a076823e654901120fae592cee8b2786321
Merge pull request #903 from Gozala/bug/tab-detraitifaction@854980
It is impossible to fix tabs without touching windows or other way round, so I'm marking this as a duplicate for windows rewrite bug, which I'll rename to windows & tabs rewrite.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 854982
You need to log in before you can comment on or make changes to this bug.