If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

HEAD http://mozilla.org returns "404 Not Found"

VERIFIED DUPLICATE of bug 107166

Status

mozilla.org Graveyard
Server Operations
VERIFIED DUPLICATE of bug 107166
17 years ago
3 years ago

People

(Reporter: Henrik Gemal, Assigned: Stephen Brown)

Tracking

Details

(Reporter)

Description

17 years ago
Something is configured wrong on mozilla.org.
If you from a unix command line performs the following command:
HEAD mozilla.org

you get:
404 Not found
Connection: close
Date: Tue, 12 Jun 2001 20:46:15 GMT
Server: Netscape-Enterprise/3.6
Content-Length: 207
Content-Type: text/html
Client-Date: Tue, 12 Jun 2001 20:45:12 GMT
Client-Peer: 207.200.81.215:80

If you do the same on netscape.com

HEAD netscape.com
200 OK
Connection: close
Date: Tue, 12 Jun 2001 20:46:22 GMT
Server: Netscape-Enterprise/4.1
Content-Length: 0
Content-Type: text/html
Client-Date: Tue, 12 Jun 2001 20:46:20 GMT
Client-Peer: 207.200.89.225:80
Set-Cookie: 
UIDC=194.192.187.68:0992378783:399753;domain=.netscape.com;path=/;expires=31-
Dec-2010 23:59:59 GM

there nothing wrong with browsing the site, it just the web server that's 
returning a wrong HTTP status code.

Btw: the same is true for www.mozilla.org

HEAD http://bugzilla.mozilla.org
works just fine, returning "200 OK"

Updated

16 years ago
Blocks: 80122
(Assignee)

Comment 1

16 years ago
This is a side effect of having "Directory Indexing" turned to off within
the Netscape Enterprise Server 3.6.  If you do a "HEAD" of a specific 
file, i.e. "HEAD mozilla.org/index.html" you will get a successful return
code and actual data returned.  We usually prefer to leave the directory
indexing feature turned off so people can't just generically troll through
the web site and find all the content.  I think in NES 4.1 you get a correct
return code in this instance, though.  I'll verify that and then see about
upgrading install base for www.mozilla.org.
Status: NEW → ASSIGNED

Comment 2

16 years ago
Please note that indexing is turned off on purpose and before touching it 
please make sure security os covered:

http://bugzilla.mozilla.org/show_bug.cgi?id=41158
Depends on: 41158

Comment 3

16 years ago

*** This bug has been marked as a duplicate of 107166 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
This one is not resolved, the error still exists!
(Reporter)

Comment 5

16 years ago
verified dupe
Status: RESOLVED → VERIFIED

Comment 6

16 years ago
NES6 correctly returns a 200 in reply to

HEAD / HTTP/1.0
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.