Element does not get visible when it should

RESOLVED DUPLICATE of bug 652991

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 652991
5 years ago
5 years ago

People

(Reporter: Yves Goergen, Unassigned)

Tracking

19 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

Steps to reproduce:

Open the website photo.unclassified.de/list/garden (link intentionally not recognisable - the site is not yet finished), then click on the first image. You can see a blue SVG circle rotating around the centre of the page. This animation is supposed to be visible every time a new image is loading. (For testing purposes, it currently remains visible for another 2 seconds before it disappears.) Then, click the small arrow on the right edge of the page to load the next image from the list. This will trigger an XMLHttpRequest to replace a div's content with something else. Before starting the request, that animation is made visible again.


Actual results:

The animation is only visible for the first image or when returning to the image first loaded. Although the display CSS attribute is correctly set and the z-index is far enough in front, the element does not appear on the screen. The same happens when resizing the browser window, in which case the current page content is reloaded for the new window size. Watching it with Firebug makes me clueless - everything it set as it should, but Firefox does not apply the CSS settings properly. This works in Chrome and IE10, it's only Firefox (up to today's Aurora build) that fails here. IE9 cannot be used for testing because I don't use XMLHttpRequest there (the history API is required to properly update the URL of the current document).


Expected results:

The animation should be visible when its display attribute is set from "none" to "", which is in the moment of clicking a previous/next link (or when resizing the window) and before loading another page begins. It will then be hidden after the image has loaded.

I've tried to create a smaller test case page but the bug does not appear there. So it must be something in the complete page which needs to be analysed.

You can also test this by manually deactivating the element's style rule in Firebug on the element with the ID "loading-div". On the first image, this shows or hides the circle. On other images, it does nothing.
Confirmed in nightly 22.0a1 (2013-03-28).
The animation is seen in Chrome, Opera.
Status: UNCONFIRMED → NEW
Component: Untriaged → SVG
Ever confirmed: true
Product: Firefox → Core

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 652991
You need to log in before you can comment on or make changes to this bug.