Closed Bug 855504 Opened 7 years ago Closed 7 years ago

[font inspector] Selecting text in the font inspector is hard

Categories

(DevTools :: Inspector, defect)

x86
All
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 25

People

(Reporter: paul, Assigned: paul)

References

Details

Attachments

(1 file)

First, double clicking on the URL doesn't appear to work (because read only?).
And with the dark theme, the contrast is too low.
Assignee: nobody → paul
Summary: [inspector] Selecting text in the font inspector is hard → [font inspector] Selecting text in the font inspector is hard
Duplicate of this bug: 883638
Attached patch Patch v1Splinter Review
Every click on the sidebar would fire a "select" event that would re-build the whole font-inspector :(
Attachment #766729 - Flags: review?(vporof)
Comment on attachment 766729 [details] [diff] [review]
Patch v1

Review of attachment 766729 [details] [diff] [review]:
-----------------------------------------------------------------

WTF!

Test? (r+ if you think it's not necessary)
Attachment #766729 - Flags: review?(vporof) → feedback+
Comment on attachment 766729 [details] [diff] [review]
Patch v1

I don't think we need a test here.
Attachment #766729 - Flags: review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/5ecea1db11aa
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/5ecea1db11aa
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 25
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.