Change - Leaving website error message should appear modal

RESOLVED INVALID

Status

Firefox for Metro
Browser
RESOLVED INVALID
5 years ago
3 years ago

People

(Reporter: kjozwiak, Assigned: TimAbraldes)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=change c=Tabs_app_bar u=metro_firefox_user p=0)

(Reporter)

Description

5 years ago
The popup that you receive when you attempt to leave a website that has information filled out should appear modal and not allow keyboard shortcuts and other actions to occur

Steps to reproduce the issue:

1) Open Firefox Metro
2) Go to stackoverflow.com and select a random question
3) Insert some text into the "Reply" field
4) Select the "X" on the tabs app bar
5) You will receive a message stating that you are about to leave and the information will not be saved
6) While the error message is visible, you will be able to execute keyboard shortcuts such as CTRL + T. You will also be able to touch and select links in the background

Current Behavior:

- User is allowed to use shortcuts and other actions while the error message is visible

Expected Behavior:

- Error message should appear modal and the user shouldn't be able to do anything until the error message is dismissed
(Reporter)

Updated

5 years ago
Blocks: 841214
(Reporter)

Updated

5 years ago
Summary: leaving website error message should appear modal → Change - Leaving website error message should appear modal
(Reporter)

Comment 1

5 years ago
it5 consideration?
Flags: needinfo?(mmucci)
Moving to Iteration #5 for consideration as a Change story.
Blocks: 850809
No longer blocks: 841214
Flags: needinfo?(mmucci)
Priority: -- → P1
QA Contact: jbecerra
Whiteboard: feature=change c=Tabs_app_bar u=metro_firefox_user p=0
Whiteboard: feature=change c=Tabs_app_bar u=metro_firefox_user p=0 → feature=change c=Tabs_app_bar u=metro_firefox_user p=2
Assignee: nobody → netzen

Updated

5 years ago
Status: NEW → ASSIGNED

Updated

5 years ago
Blocks: 855905
No longer blocks: 850809
Assignee: netzen → tabraldes
There are a whole bunch of issues with dialogs currently.  I've filed bug 866304 to track them, and I believe that they should all be fixed in one swoop by partially rewriting PromptService.js.  I'll mark this bug resolved since we'll track it and the others in bug 866304.  If we decide to split that bug up, we can reopen this one.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
No longer blocks: 855905
Priority: P1 → --
Whiteboard: feature=change c=Tabs_app_bar u=metro_firefox_user p=2 → feature=change c=Tabs_app_bar u=metro_firefox_user p=0
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.