The default bug view has changed. See this FAQ.

Get New Messages for all accounts does not work

RESOLVED FIXED in Thunderbird 23.0

Status

MailNews Core
Networking: POP
--
blocker
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Sven Grull, Assigned: neil@parkwaycc.co.uk)

Tracking

({regression})

Trunk
Thunderbird 23.0
regression

SeaMonkey Tracking Flags

(thunderbird22+ fixed, seamonkey2.19?)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:22.0) Gecko/20100101 Firefox/22.0 SeaMonkey/2.19a1
Build ID: 20130327003001

Steps to reproduce:

With recent trunk builds get New Messages for all accounts does not work anymore. Either invoked via menu or shortcut. It happens also in safe mode.

Output of error console:
Error: [Exception... "Not enough arguments [nsIPop3IncomingServer.downloadMailFromServers]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://messenger/content/mailTasksOverlay.js :: MailTasksGetMessagesForAllServers :: line 134"  data: no]
Source File: chrome://messenger/content/mailTasksOverlay.js
Line: 140

Comment 1

4 years ago
Regressed by bug 831993.
This also affects Thunderbird in the same way.

I could almost fix this myself but I am not sure what type of array needs to be passed from Javascript to the new function. Neil changed the C++ function to take an array of nsIPop3IncommingServers, which is unfamiliar to me (it is not nsIArray or similar).
Blocks: 831993
Severity: normal → blocker
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows XP → All
Hardware: x86 → All

Comment 2

4 years ago
The message for TB is:
[Exception... "Not enough arguments [nsIPop3IncomingServer.downloadMailFromServers]"  nsresult: "0x80570001 (NS_ERROR_XPC_NOT_ENOUGH_ARGS)"  location: "JS frame :: chrome://messenger/conte
nt/mailWindowOverlay.js :: MsgGetMessagesForAllServers :: line 1433"  data: no]

There are 2 spots where this function is used in TB.
(Reporter)

Updated

4 years ago
Component: MailNews: General → Networking: POP
Product: SeaMonkey → MailNews Core

Comment 3

4 years ago
The files where this needs to be fixed are separate for TB and SM but I think we can fix it together in this one bug.
tracking-seamonkey2.19: --- → ?
tracking-thunderbird22: --- → ?
tracking-thunderbird22: ? → +
(Assignee)

Comment 4

4 years ago
Created attachment 731007 [details] [diff] [review]
Possible patch

I modernised the Thunderbird code to bring it more into line with SeaMonkey and incidentally remove another nsISupportsArray.

The interesting bit is in the very last patch hunk, the rest is just nsISupportsArray removal noise.
Assignee: nobody → neil
Status: NEW → ASSIGNED
Attachment #731007 - Flags: review?(acelists)

Comment 5

4 years ago
Comment on attachment 731007 [details] [diff] [review]
Possible patch

Yes, this seems to work for me on TB.
Attachment #731007 - Flags: review?(mkmelin+mozilla)
Attachment #731007 - Flags: review?(acelists)
Attachment #731007 - Flags: feedback+

Updated

4 years ago
Attachment #731007 - Flags: review?(mbanner)

Comment 6

4 years ago
Comment on attachment 731007 [details] [diff] [review]
Possible patch

Review of attachment 731007 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/base/content/mailWindowOverlay.js
@@ +2688,5 @@
>      {
>        inboxFolder.biffState =  Components.interfaces.nsIMsgFolder.nsMsgBiffState_NoMail;
>        inboxFolder.clearNewMessages();
>      }
> +    localFoldersToDownloadTo.push(inboxFolder);

i guess we can drop the |if (inboxFolder)| above.
or else we're just pushing null
Attachment #731007 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 7

4 years ago
Pushed comm-central changeset f3890baa9684.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 23.0
(Assignee)

Comment 8

4 years ago
Comment on attachment 731007 [details] [diff] [review]
Possible patch

[Approval Request Comment]
Regression caused by (bug #): 831993
Attachment #731007 - Flags: approval-comm-aurora?

Updated

4 years ago
Attachment #731007 - Flags: review?(mbanner)
Comment on attachment 731007 [details] [diff] [review]
Possible patch

Yep, a=me. I'll land this in a bit, as I'm landing other things as well.
Attachment #731007 - Flags: approval-comm-aurora? → approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/7c7e93acfc7d
status-thunderbird22: --- → fixed
You need to log in before you can comment on or make changes to this bug.