Firefox Nighty 22.0a1 opens blank page instead of calling the third-party PDF reader plugin

VERIFIED FIXED in Firefox 22

Status

()

Firefox
PDF Viewer
P1
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rshimazu, Assigned: yury)

Tracking

({regression})

22 Branch
Firefox 23
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(firefox21 unaffected, firefox22+ verified, firefox23 verified)

Details

(Whiteboard: [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20130327 Firefox/22.0
Build ID: 20130327031035

Steps to reproduce:

With Firefox Nighty 22.0a1, I tried to disable pdf.js.




Actual results:

With Firefox Nighty 22.0a1 I have to set pdfjs.disabled true in about:config after I change PDF handler from "Preview in Nighty" to "Use Adobe Acrobat in Nighty" (Tools->Option->Applications).


Expected results:

With Firefox 20 beta I just have to change PDF handler at Tools->Option->Application. I just do not need to change settings in about:config.
So I expect that to disable pdf.js is easier with Firefox Nighty 22.0a1 as well.
(Reporter)

Comment 1

4 years ago
If I just change PDF handler from "Preview in Nighty" to "Use Adobe Acrobat in Nighty" (Tools->Option->Applications) without changing the settings in about:config, I just can not see any PDFs within the browser. All blank(white) PDFs. With Firefox Nighty 22.0a1, I need to change the settings in about:config as well and have to set pdfjs.disabled true.

This setting is too difficult for ordinary people. So I want this setting as easy as Firefox 20 beta.
(Reporter)

Comment 2

4 years ago
I did further tests with Firefox Aurora 21.0a2.

*Firefox 21.0.a2 without installing pdf.js addon. --> No problem.
(The version of pdf.js is 0.7.236)

*Firefox 21.0.a2 with pdf.js(0.7.361) addon -> No problem.

*Firefox 21.0.a2 with pdf.js(0.7.369) addon-> I see the problem when enabling Adobe Reader.

So it seems that the problem begins with 0.7.369.

I guess this issue is related with the fix in Bug 738967

Comment 3

4 years ago
Yes, it's a recent regression, I can cofirm too with Zeon Plus plugin. Using a 3rd-party PDF reader plugin (in Options > Applications) opens blank page instead of caling the plugin to open the PDF document.

Regression range:
m-c
good=2013-03-26
bad=2013-03-27
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=456cb08f8509&tochange=178a4a770bb1

Suspected bug:
Ryan VanderMeulen — Bug 852981 - Update pdf.js to version 0.7.390. r=bdahl
Blocks: 852981
Status: UNCONFIRMED → NEW
status-firefox21: --- → unaffected
tracking-firefox22: --- → ?
Component: Untriaged → PDF Viewer
Ever confirmed: true
Keywords: regression
Summary: Firefox Nighty 22.0a1 : To disable pdf.js is troublesome. → Firefox Nighty 22.0a1 opens blank page instead of calling the third-party PDF reader

Updated

4 years ago
Summary: Firefox Nighty 22.0a1 opens blank page instead of calling the third-party PDF reader → Firefox Nighty 22.0a1 opens blank page instead of calling the third-party PDF reader plugin
(Assignee)

Updated

4 years ago
Priority: -- → P1
Whiteboard: [pdfjs-c-integration]
(Assignee)

Comment 4

4 years ago
fwiw interesting workaround:
1. in Options > Applications, for PDF select "Always Ask" and apply changes
2. in Options > Applications, for PDF select "Use Adobe Acrobat (in Nighty)" and apply changes;
(Assignee)

Updated

4 years ago
Whiteboard: [pdfjs-c-integration] → [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3012
No longer blocks: 852981
Depends on: 856383
(Reporter)

Comment 5

4 years ago
I tested again with Firefox 22.0a1 (2013-04-01).
Without pdf.js addon 0.7.423 it is now fine. In other words, if I disable pdf.js addon at Add-ons Manager, it is fine.

But with pdf.js addon 0.7.423 the problem still seems to continue.
(Assignee)

Comment 6

4 years ago
> But with pdf.js addon 0.7.423 the problem still seems to continue.

Uninstall the addon -- I am not sure why you will need it

Comment 7

4 years ago
(In reply to Yury Delendik (:yury) from comment #6)
> > But with pdf.js addon 0.7.423 the problem still seems to continue.
> 
> Uninstall the addon -- I am not sure why you will need it

Won't this affect a large number of users? Or are you suggesting that only those who installed external versions of PDF.js are affected.
(Assignee)

Comment 8

4 years ago
(In reply to Alex Keybl [:akeybl] from comment #7)

> those who installed external versions of PDF.js are affected.

I think the reporter mean, those who installed external versions of PDF.js and selected not to preview PDF with Tools->Option->Applications. That's unreal use case IMHO

Comment 9

4 years ago
I can reproduce the problem without any addon.

http://hg.mozilla.org/mozilla-central/rev/0b7c27024048
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130401 Firefox/22.0 ID:20130401030817
(Assignee)

Comment 10

4 years ago
(In reply to Alice0775 White from comment #9)
> I can reproduce the problem without any addon.
> 
> http://hg.mozilla.org/mozilla-central/rev/0b7c27024048
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130401 Firefox/22.0
> ID:20130401030817

The fix was merged today with bug 856383

https://hg.mozilla.org/mozilla-central/rev/77578bde1c1c
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

4 years ago
(In reply to Yury Delendik (:yury) from comment #8)
> I think the reporter mean, those who installed external versions of PDF.js
> and selected not to preview PDF with Tools->Option->Applications. That's
> unreal use case IMHO

Yes, it is a rare case. If the case is that those who installed external version of PDF.js will keep seeing PDFs with pdf.js unless they disable external version of PDF.js, it is just fine. 

But in reality, those who installed external version of PDF.js, once they selected not to preview PDF with Tools->Option->Application, will see a blank page (No pdf at all) unless they disable external version of PDF.js. They can not see any PDF with pdf.js addon nor with Adobe Reader. This is confusing at least to me.

When they select not to preview PDF with Tools->Option->Application, if external version of pdf.js is automatically disabled, it is fine, but this may not be what I should discuss here.
(Assignee)

Comment 12

4 years ago
That would be an issue with the extension and must be tracked at https://github.com/mozilla/pdf.js/issues . I guess we have to disable the embed tag support for the extension.
(Assignee)

Comment 13

4 years ago
Something is missing, after Firefox is restarted the problem appearing again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 14

4 years ago
Yes, it started again with Firefox 23.0a1 (2013-04-02).
If a fix for Bug 738967 is the cause, how about removing the fix for Bug 738967 for the moment?
In my opinion, to support for embedded PDF with pdf.js is not essential at all.
(Assignee)

Updated

4 years ago
Whiteboard: [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3012 → [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036
(Reporter)

Comment 15

4 years ago
I tested again width Aurora 22.0a2 (2013-04-05) and with Nighty 23.0a1 (2013-04-06).
But it does not seem to me that the problem has been fixed. 

> https://github.com/mozilla/pdf.js/pull/3036
Has this fix not been applied yet?

Updated

4 years ago
status-firefox22: --- → affected
tracking-firefox22: ? → +

Updated

4 years ago
Assignee: nobody → ydelendik
(Assignee)

Updated

4 years ago
Depends on: 861399
No longer depends on: 856383
(Assignee)

Comment 16

4 years ago
Fixed in Nightly (4-17-2013)
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

4 years ago
Created attachment 738545 [details] [diff] [review]
Fixes pdf application switching (for aurora uplift)

https://tbpl.mozilla.org/?tree=Try&rev=d2ed080c3810
(Assignee)

Comment 18

4 years ago
Comment on attachment 738545 [details] [diff] [review]
Fixes pdf application switching (for aurora uplift)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 738967
User impact if declined: Unable to switch to the third-party PDF Viewer plugin
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, affects internal PDF Viewer logic responsible for its enabling/disabling
String or IDL/UUID changes made by this patch: --
Attachment #738545 - Flags: review?(bdahl)
Attachment #738545 - Flags: approval-mozilla-aurora?
(Reporter)

Comment 19

4 years ago
(In reply to Yury Delendik (:yury) from comment #16)
> Fixed in Nightly (4-17-2013)

I also confirmed the fix in Nightly (4-17-2013). Thank you.

Updated

4 years ago
Duplicate of this bug: 863269
Comment on attachment 738545 [details] [diff] [review]
Fixes pdf application switching (for aurora uplift)

Review of attachment 738545 [details] [diff] [review]:
-----------------------------------------------------------------

Also reviewed by mossop in https://github.com/mozilla/pdf.js/pull/3036#issuecomment-15856712
Attachment #738545 - Flags: review?(bdahl) → review+

Updated

4 years ago
Attachment #738545 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
Whiteboard: [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036 → [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036, checkin for aurora uplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/6e68a0402b97

Fixed on trunk by bug 861399.
status-firefox22: affected → fixed
status-firefox23: --- → fixed
Keywords: checkin-needed
Whiteboard: [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036, checkin for aurora uplift → [pdfjs-c-integration] https://github.com/mozilla/pdf.js/pull/3036
Target Milestone: --- → Firefox 23
Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20100101 Firefox/22.0
Mozilla/5.0 (Windows NT 6.0; rv:24.0) Gecko/20130523 Firefox/24.0

Verified as fixed in Firefox 22 beta 2 (buildID: 20130521223249) and latest Nightly (buildID: 20130523030935).
status-firefox22: fixed → verified
(Reporter)

Comment 24

4 years ago
It seems that Aurora 24.0a2 (2013-06-29) and Nighty 25.0.a1 have the same issue again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 25

4 years ago
(In reply to rshimazu from comment #24)
> It seems that Aurora 24.0a2 (2013-06-29) and Nighty 25.0.a1 have the same
> issue again.

Please file a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 26

4 years ago
(In reply to rshimazu from comment #24)
> It seems that Aurora 24.0a2 (2013-06-29) and Nighty 25.0.a1 have the same
> issue again.

(In reply to Alice0775 White from comment #25)
> (In reply to rshimazu from comment #24)
> > It seems that Aurora 24.0a2 (2013-06-29) and Nighty 25.0.a1 have the same
> > issue again.
> 
> Please file a new bug.

already filed, see Bug 879161
Mozilla/5.0 (Windows NT 6.0; rv:23.0) Gecko/20100101 Firefox/23.0

Verified as fixed in Firefox 23 beta 5 (build ID: 20130711122148).
Status: RESOLVED → VERIFIED
status-firefox23: fixed → verified
You need to log in before you can comment on or make changes to this bug.