Last Comment Bug 855726 - Copy actions are broken o HTML5 videos
: Copy actions are broken o HTML5 videos
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: 20 Branch
: x86 All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-28 09:04 PDT by Simona B [:simonab]
Modified: 2013-04-02 14:26 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
-
wontfix
unaffected
unaffected
20+


Attachments

Description Simona B [:simonab] 2013-03-28 09:04:24 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130326150557

Steps to reproduce:
1. Go to http://youtube.com/html5 and enable the HTML5 demo.
2. Copy some text from anywhere.
2. Go back to YouTube, play a video of your choice, right click on it and select "Copy Video URL".
3. Open a new tab and paste the copied URL.

Expected results:
The copied URL is pasted in the new tab.

Actual results:
Nothing is pasted in the URL bar (not even what was copied in step 2). The same behavior is encountered also for the other copy options: "Copy video URL at current time", "Copy embed HTML" and "Copy debug info".

Note:
The issue is not reproducible on the latest Nightly and on the latest Aurora.
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:22.0) Gecko/20130328 Firefox/22.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:21.0) Gecko/20130328 Firefox/21.0
Comment 1 Simona B [:simonab] 2013-03-28 09:11:59 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307023931

This is also reproducible also on Firefox 19.0.2. Is there any chance that this gets fixed on Firefox 20? Should I keep working on the regression range?
Comment 2 Josh Matthews [:jdm] 2013-03-29 09:50:37 PDT
This is almost certainly not an issue that would cause a fix to be uplifted to FF 20 before release or cause a chemspill.
Comment 3 Josh Matthews [:jdm] 2013-03-29 09:51:32 PDT
However, we should probably note it as a known issue.
Comment 4 Alex Keybl [:akeybl] 2013-03-29 14:31:16 PDT
Not worth tracking, still considering a relnote.
Comment 5 Simona B [:simonab] 2013-04-01 04:29:49 PDT
Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

The issue is also reproducible on Firefox 12. On the previous Firefox versions < than 12 the selection in the copy dialog was not done and was impossible to do any copy actions.

The issue was fixed in Firefox 21.0a1:
Last bad nightly: 2013-01-24
First good nightly: 2013-01-25
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=98ea4d294369&tochange=a207f33adc1a
Comment 6 Chris Pearce (:cpearce) 2013-04-01 13:04:13 PDT
"Copy Video URL" doesn't work in Chrome either. I'd guess this is a bug in YouTube's code.
Comment 7 Simona B [:simonab] 2013-04-02 00:25:23 PDT
(In reply to Chris Pearce (:cpearce) from comment #6)
> "Copy Video URL" doesn't work in Chrome either. I'd guess this is a bug in
> YouTube's code.

Copying the video URL works for me in Chrome 26.0.1410.43 m.
Comment 8 Chris Pearce (:cpearce) 2013-04-02 14:26:12 PDT
Indeed "Copy Video URL" does now work in Chrome. It also now works for me in [Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20130402 Firefox/23.0].

I guess YouTube fixed their bug.

Note You need to log in before you can comment on or make changes to this bug.