Closed Bug 855792 Opened 8 years ago Closed 7 years ago

CE requirement on maximum volume

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:tef+, b2g18 verified, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 verified)

VERIFIED FIXED
1.0.1 IOT1 (10may)
blocking-b2g tef+
Tracking Status
b2g18 --- verified
b2g18-v1.0.0 --- wontfix
b2g18-v1.0.1 --- verified

People

(Reporter: jcheng, Assigned: GaryChen)

References

Details

(Keywords: late-l10n, Whiteboard: [status: patch in the works])

Attachments

(4 files)

If the acoustic output exceeds 85dB from the earphone, the handset should react a
warning notice to the user and warn again in 20 hours. or the output from earphone should not exceed 85dB
One partner agreed to implement it and contribute the codes to Mozilla's repository.
Assignee: nobody → terry.yin
Hi Terry, not sure if you have any update here? Thanks
Flags: needinfo?(terry.yin)
Hi joe, we are reviewing code ourselves and will contribute the code soon.
Flags: needinfo?(terry.yin)
Attached patch PatchSplinter Review
Dear JCheng:
  Please help to review the patch,thanks.
Attachment #737804 - Flags: review?(jcheng)
(In reply to qingluo.wang from comment #4)
> Created attachment 737803 [details] [diff] [review]
> The patch file for this requiremtn.
I'm so sorry that when attached the patch,I forgot to add the reviewer,so I attach the file again,and this one is useless,please be noted,thanks.
Comment on attachment 737804 [details] [diff] [review]
Patch

Hi Jonas, mind taking an initial look? or reassign as you see fit? Thanks
Attachment #737804 - Flags: review?(jcheng) → review?(jonas)
Comment on attachment 737804 [details] [diff] [review]
Patch

Sorry, I don't think using app dialog makes sense.
It would annoy the user if he needs to press "OK I know I am listening volume>=10" every minute.
Is this part of CE requirement?
Attachment #737804 - Flags: review?(jonas) → review-
(In reply to Joe Cheng [:jcheng] from comment #0)
> If the acoustic output exceeds 85dB from the earphone, the handset should
> react a
> warning notice to the user and warn again in 20 hours. or the output from
> earphone should not exceed 85dB

What's the actual and accurate requirement?
https://bugzilla.mozilla.org/show_bug.cgi?id=863267#c0 said another similar req but different in detail.

(In reply to leo.bugzilla.gaia from comment #0)
> [CE Certification]
> The device shall have achieved CE Certification :
> Pop-up window of warning & volume control shall be appeared in case that
> sound pressure exceeds 85 dBA and output exceeds 27mV with ear-mic plugged
> in.
> 
> Case 1: When user control a media volume over 85db
> * Should be displayed warning toast like this "If you listen at high volume
> levels for long periods, hearing damage can occur."
> * when control a media volume using SUK and other ways
> 
> Case 2: The previous media vol status is over 85db and when user repluged
> ear-mic
> * Should be displayed warning toast like this "Media volume automatically
> turned down to protect your ears."
> * If there is no running Media apps, do not display warning toast.
> * If any media apps are running, should be displayed warning toast.
(In reply to Alive Kuo [:alive] from comment #8)
> Comment on attachment 737804 [details] [diff] [review]
> Patch
> 
> Sorry, I don't think using app dialog makes sense.
> It would annoy the user if he needs to press "OK I know I am listening
> volume>=10" every minute.

After looking again, the code says they will check if the playing time is over 20 hours every minute. Sorry.
But I still don't know where does the value come from. Is it also the requirement?

> Is this part of CE requirement?
(In reply to Alive Kuo [:alive] from comment #8)
> Comment on attachment 737804 [details] [diff] [review]
> Patch
> 
> Sorry, I don't think using app dialog makes sense.
> It would annoy the user if he needs to press "OK I know I am listening
> volume>=10" every minute.
> Is this part of CE requirement?

Hi:
  This is follow our android product's design,and the spec defines follow points:
1>The phone should detect volume when inserting earphone: Press the volume + key,if exceed warning level,prompt “raise volume above safe level...”to user.After user click ok,If user unplug earphone and insert again,don't prompt and keep volume level before

2.If the volume is above warning level, restart and Insert earphones,volume will be restore to a safe level ,Include power off ,then power on

3.When user is playing to music/movie/radio with earphone, and the volume is above warning level, if the time last for more than 20h, recover the volume to safe level and prompt “raise volume above safe level...”to user.

· If user click OK, then continue playing music in safe
level. If user increase volume later, restart timing.

· If user click Cancel, refer to step 1.

· If user unplug earphone and insert again, restart
timing.

· If restart and power on,restart timing.


According to the similar req,maybe I need to persuade our UE team to change the spec.To be honest,using app dialog makes sense is a bad design for me.
==> _volWarningLvl: 10,//85 db, the warning level for sound via headset.
Every devices has differnet output level, I think it's better to have an customize attribute for this purpose.
adding Moz UX. 
You can see this behavior in partner build already.
The UX problem I see:
1. The user must listen with earphone to reach 20 hours to show the message is really too long.
And the user who's listening music won't see the dialog after playing a long time..
2. The confirm dialog is noisy, do we really need to block the user by a dialog to "confirm I'm really want to play music with volume>10?
Component: Gaia → Gaia::System
Summary: CE requirement → CE requirement on maximum volume
Should it be a tef+ bug?
blocking-b2g: --- → tef?
Please see the part Zx.2 Equipment requirements of the attachement EN 60950-1_A12_2011.pdf,this is CE certification requirements,if our handset can not meet this requirement,we can't pass the CE certification.
Whiteboard: [tef-triage]
Daniel this still looks to be a certification requirement - can you provide reasoning for putting it to [tef-triage]?
Flags: needinfo?(dcoloma)
Whiteboard: [tef-triage]
(In reply to Alive Kuo [:alive])
See Also: https://bugzilla.mozilla.org/show_bug.cgi?id=863267

Why not we close one as dup, either this bug or 863267? They seem the same.
I don't know if the devices are going to be ever in the situation the CE requirement describes. I think this might be OEM dependant.
Flags: needinfo?(dcoloma)
hi Daniel:
This is CE cetification new requirement,
Equipment requirements:
- equipment provided as a package (personal music player with its listening device), where the acoustic output L Aeq,T is <= 85 dBA measured while playing the fixed "programme simulation noise" as described in EN 50332-1; and
- a personal music player provided with an analogue electrical output socket for a listening device, where the electrical output is<= 27 mV measured as described in EN 50332-2, while playing the fixed "programme simulation noise" as described in EN 50332-1.
but our handset can't meet this requirement,so we must accord with All other equipment:
a) protect the user from unintentional acoustic outputs exceeding those mentioned above;
and
b) have a standard acoustic output level not exceeding those mentioned above, and
automatically return to an output level not exceeding those mentioned above when the
power is switched off; and
c) provide a means to actively inform the user of the increased sound pressure when the
equipment is operated with an acoustic output exceeding those mentioned above. Any
means used shall be acknowledged by the user before activating a mode of operation
which allows for an acoustic output exceeding those mentioned above. The
acknowledgement does not need to be repeated more than once every 20 h of cumulative
listening time; and
NOTE 2 Examples of means include visual or audible signals. Action from the user is always required.
NOTE 3 The 20 h listening time is the accumulative listening time, independent how often and how long the personal music
player has been switched off.
d) have a warning as specified in Zx.3; and.

so now we need tef confirm this reqierement,and then we will push mozilla to make some change.
Hi, 

I think this is also related with: 
https://bugzilla.mozilla.org/show_bug.cgi?id=863267

CE certificate is a mandatory requirement for all European countries and carriers (legal requirement). 

My doubt is if the device is able to exceed 85dBs. If the device would not be able to exceed that limit, I understand that it'd be not needed to implement this. 

Vendor colleagues, could you please confirm if your device can excceed 85dB in audio?

Thanks!
David
I've been told that the device will exceed that volume, so we need to tef+
blocking-b2g: tef? → tef+
(In reply to Daniel Coloma:dcoloma from comment #22)
> I've been told that the device will exceed that volume, so we need to tef+

The currently proposed patch had a string change, in which case this would need to land for 5/10.

Can we not make this completely POVB given the late strings and new functionality? Bug 863267 will cover the case where we want to warn the user.
Flags: needinfo?(dcoloma)
Target Milestone: --- → 1.0.1 IOT1 (10may)
I posted a UX proposal in bug 863267, attachment ID 746132.

The document summarizes my understanding of the requirement along with key flows. I'd appreciate if someone more familiar with the standard could review the document to confirm.
Assignee: terry.yin → gchen
The plan now is: Gary will try to finish the patch from TCL in time so that we could have such support in the open source'd Gaia.
Whiteboard: [status: patch in the works]
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) from comment #25)
> The plan now is: Gary will try to finish the patch from TCL in time so that
> we could have such support in the open source'd Gaia.

Is this the absolute lowest effort way to resolve the requirement of not exceeding a maximum value? I'm hoping the patch you're referring to was build time. Basically, somebody needs to answer comment 23.

Also, will the patch land today or tomorrow?
Comment on attachment 747376 [details]
pull request:https://github.com/mozilla-b2g/gaia/pull/9636

r+ with github comments addressed. Great work Gary!
Attachment #747376 - Flags: review?(alive) → review+
This bug was partially uplifted.

Uplifted 0e887e03411e76a46fce7b1e2f46c54265a90cae to:
v1-train: 32fa4ad74ee9c489fb2ff4d590146858936b3777

Commit 0e887e03411e76a46fce7b1e2f46c54265a90cae didn't uplift to branch v1.0.1
Flags: needinfo?(gchen)
(In reply to John Ford [:jhford] -- If you expect a reply from me, use needsinfo? instead of CC from comment #30)
> This bug was partially uplifted.
> 
> Uplifted 0e887e03411e76a46fce7b1e2f46c54265a90cae to:
> v1-train: 32fa4ad74ee9c489fb2ff4d590146858936b3777
> 
> Commit 0e887e03411e76a46fce7b1e2f46c54265a90cae didn't uplift to branch
> v1.0.1

fixed conflict.
Flags: needinfo?(gchen)
Keywords: late-l10n
Depends on: 872632
Flags: needinfo?(dcoloma)
No longer depends on: 872632
See Also: → 878662
Duplicate of this bug: 863267
The issue is no longer reproduces
The warning message appears and the volume is reduced automatically after 20 hours of listening in full volume blast

Environmental  Variables:
Build ID: 20130624070224
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/62049a1c5d36
Gaia: 885b874029d8143035765ae903c147a9415fcc52
Platform Version: 18.0


Environmental  Variables:
Build ID: 20130624070215
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9c62297d11b0
Gaia: 93241eb6c5d6c110710fad8da3ccd4423312b0c9
Platform Version: 18.0
Status: RESOLVED → VERIFIED
See Also: → 1112586
You need to log in before you can comment on or make changes to this bug.