copy paste from remote X applications is not working

VERIFIED DUPLICATE of bug 55312

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 55312
17 years ago
14 years ago

People

(Reporter: jason, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-SGI_XFS_1.0 i686; en-US; rv:0.9.1)
Gecko/20010608
BuildID:    2001060810

If I launch a local xterm and then highlight some url, middle clicking
in mozilla causes the URL to be fetched.  That's good.

If I launch an xterm from a remote computer and then highlight some url, middle
clicking does not cause anything noticeable to happen.  This is bad.  It also
doesn't work for a remote emacs, etc.

This buggy behavior is consistent with the behavior I got from the .7 release
that came with Redhat 7.1 by default (I upgraded to a new rpm before filing this
bug).

This does not happen with Netscape 4.76 however.  It likes text from local or
remote xterms.

Reproducible: Always
Steps to Reproduce:
1. Launch an xterm from a remote machine onto a local machine
2. Type a URL and then highlight it
3. Middle click on a Mozzila window and nothing will happen
4. Perform these same steps with a local xterm and it will fetch the URL.


Actual Results:  Nothing happens. :(

Expected Results:  Mozzilla should fetch the page in the x cut buffer no matter
if it is from a local application or a remote one

The remote machine is running an old version of Redhat, maybe Redhat 6.1 or 6.2

The local machine is running a pretty vanilla server installation of
Redhat 7.1
A temporary sort-of-fix for this was checked in on June 8.  That should cover
most cases.

The permanent fix is bug 84973. 



*** This bug has been marked as a duplicate of 55312 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.