ConnectViaTransportFlow avoids using signals on Mainthread

RESOLVED DUPLICATE of bug 855623

Status

()

Core
WebRTC: Networking
P2
normal
RESOLVED DUPLICATE of bug 855623
5 years ago
5 years ago

People

(Reporter: jesup, Assigned: jesup)

Tracking

(Depends on: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webrtc][blocking-webrtc-])

(Assignee)

Description

5 years ago
ConnectViaTransportFlow does: mTransportFlow->SignalPacketReceived.connect() on Mainthread.

Either it needs to thunk to STS thread, or we need to switch the sigslot stuff to threadsafe.  Marking blocked by the bug for switching sigslots
(Assignee)

Updated

5 years ago
Assignee: nobody → rjesup
Priority: -- → P2
(Assignee)

Comment 1

5 years ago
I ended up fixing this by thunking to STS thread in Connect*()
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Summary: ConnectViaTransportFlow uses signals on Mainthread → ConnectViaTransportFlow avoids using signals on Mainthread
Whiteboard: [webrtc][blocking-webrtc+] → [webrtc][blocking-webrtc-]
Duplicate of bug: 855623
You need to log in before you can comment on or make changes to this bug.