Bug 856469 (SQLite3.7.16.1)

Upgrade to SQLite 3.7.16.1

RESOLVED FIXED in Firefox 22

Status

()

Toolkit
Storage
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

(Blocks: 1 bug)

Trunk
mozilla23
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox22 fixed, firefox23 fixed)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #853266 +++

(In reply to Marco Bonardo [:mak] (Away Mar 27 - Apr 2) from bug 853266 comment #2)
> Comment on attachment 727469 [details] [diff] [review]
> Upgrade to SQLite 3.7.16 - Mozilla changes
> 
> Review of attachment 727469 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> OK, the current pending changes in the SQLite timeline don't seem to affect
> our usage, thus an immediate 3.7.16.1 we may need is unlikely for now.

Still standing behind that statement? :)

SQLite Release 3.7.16.1 On 2013-03-29 (3.7.16.1)

    Fix for a bug in the ORDER BY optimizer that was introduced in version 3.7.15 which would sometimes optimize out the sorting step when in fact the sort was required. Ticket a179fe7465
    Fix a long-standing bug in the CAST expression that would recognize UTF16 characters as digits even if their most-significant-byte was not zero. Ticket 689137afb6da41.
    Fix a bug in the NEAR operator of FTS3 when applied to subfields. Ticket 38b1ae018f.
    Fix a long-standing bug in the storage engine that would (very rarely) cause a spurious report of an SQLITE_CORRUPT error but which was otherwise harmless. Ticket 6bfb98dfc0c.
    The SQLITE_OMIT_MERGE_SORT option has been removed. The merge sorter is now a required component of SQLite.
    Fixed lots of spelling errors in the source-code comments 

Green on Try.
https://tbpl.mozilla.org/?tree=Try&rev=1cfc15beded8
(Assignee)

Comment 1

5 years ago
Created attachment 731705 [details] [diff] [review]
Upgrade to SQLite 3.7.16.1 - Mozilla changes
Assignee: nobody → ryanvm
Status: NEW → ASSIGNED
Attachment #731705 - Flags: review?(mak77)
(In reply to Ryan VanderMeulen [:RyanVM] from comment #0)
>     Fix for a bug in the ORDER BY optimizer that was introduced in version
> 3.7.15 which would sometimes optimize out the sorting step when in fact the
> sort was required. Ticket a179fe7465

This is something we may care about, all of the rest looks just small bugfix but unlikely affecting us.

Though, I think doesn't make much sense to have Firefox 22 on 3.7.16 and Firefox 23 on 3.7.16.1. Since we are very very early after the merge I think we should uplift this version and keep nightly and aurora coherent.

Updated

5 years ago
Attachment #731705 - Flags: review?(mak77) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 731705 [details] [diff] [review]
Upgrade to SQLite 3.7.16.1 - Mozilla changes

https://hg.mozilla.org/integration/mozilla-inbound/rev/3e311d250b6e
https://hg.mozilla.org/integration/mozilla-inbound/rev/079495f97d60

[Approval Request Comment]
Bug caused by (feature/regressing bug #): See comment 2
User impact if declined: See comment 2
Testing completed (on m-c, etc.): On inbound
Risk to taking this patch (and alternatives if risky): Minimal
String or IDL/UUID changes made by this patch: None
Attachment #731705 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/mozilla-central/rev/3e311d250b6e
https://hg.mozilla.org/mozilla-central/rev/079495f97d60
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → mozilla23

Comment 5

5 years ago
Comment on attachment 731705 [details] [diff] [review]
Upgrade to SQLite 3.7.16.1 - Mozilla changes

Early enough in the Aurora cycle that we won't suffer from a lack of testing here.
Attachment #731705 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/eb4b54955d9c
https://hg.mozilla.org/releases/mozilla-aurora/rev/7112ed1daa9e
status-firefox22: --- → fixed
status-firefox23: --- → fixed
(Assignee)

Updated

5 years ago
Blocks: 874171

Updated

4 years ago
Blocks: 853091
You need to log in before you can comment on or make changes to this bug.