Closed Bug 856662 Opened 7 years ago Closed 6 years ago

el-nacional.com doesn't recognize B2G UA as mobile

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: lcamacho, Assigned: lcamacho)

References

()

Details

(Whiteboard: [serversniff] [country-ve] [contactready])

I've been checking popular sites in Venezuela and found that el-nacional.com doesn't send the mobile version when using Firefox OS simulator.
(w/o www in URL this site has a redirect loop)
Assignee: nobody → leonard.camacho
After 20 min with el-nacional.com webmaster this has been fixed. Tested on ZTE Open.
Confirmed that I get sent to http://m.el-nacional.com/. Thanks Leonard!
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Unfortunately this site regressed and now sends desktop content again.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(but it seems they just dropped redirecting to their mobile site altogether?)
Status: REOPENED → NEW
They remove the redirection from what I can see in the scripts but m.el-nacional.com is working; I've been trying making contact again but they doesn't respond.
Maybe they aren't actually aware that their desktop->mobile redirection logic stopped working entirely?
On the server side, same behavior for iOS and Firefox OS.
On the client side too, so not sure it is a regression, more like a change in terms of business strategies or mistakes.

I would be inclined to keep it RESOLVED ;)
 

→ echo "";echo ""; URI='http://www.el-nacional.com/' ; echo "# iOS SAFARI"; htt
p --print hH GET $URI "User-Agent: $APHUA"  ;echo "# FIREFOX OS"; http --print 
hH GET $URI "User-Agent: $FOSUA" 


# iOS SAFARI
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.el-nacional.com
User-Agent:  Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

HTTP/1.1 200 OK
Accept-Ranges: bytes
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 38070
Content-Type: text/html; charset=UTF-8
Date: Fri, 07 Feb 2014 17:36:14 GMT
Server: nginx
Vary: Accept-Encoding,User-Agent

# FIREFOX OS
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.el-nacional.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Connection: keep-alive
Content-Encoding: gzip
Content-Length: 38070
Content-Type: text/html; charset=UTF-8
Date: Fri, 07 Feb 2014 17:36:15 GMT
Server: nginx
Vary: Accept-Encoding,User-Agent
I'll leave that up to Leonard - if he can find them time to send them a note asking if this was intentional, he can - if not he can suggest we close it. We're mostly worried about sites where Firefox / Firefox OS users get a *worse* user experience than other users do.
Whiteboard: [serversniff] [country-ve] [contactready]
I think this bug could be closed because el-nacional.com hasn't reinserted their code to redirect clients to their mobile site in months so this seems to be the desired behaviour.

If they start again redirecting clients this could be reopened.
I agree. Thanks!
Status: NEW → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.