Closed Bug 857043 Opened 11 years ago Closed 3 years ago

crash in nsTreeRows::FindByResource after adding new mail account

Categories

(SeaMonkey :: MailNews: Backend, defect)

x86
All
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: wsmwk, Unassigned)

References

Details

(Keywords: crash, reproducible)

Crash Data

#33 seamonkey crash (not including hangs) when counting all versions.

comments describe several problems: adding folders, adding account, unable to DL mail, etc. unclear if there is only one cause

bp-72cafc21-78dd-4883-b121-c7e562130312 
Tried to insert a new folder under inboxx
0	xul.dll	nsTreeRows::FindByResource	content/xul/templates/src/nsTreeRows.cpp:156
1	xul.dll	nsXULTreeBuilder::HasGeneratedContent	content/xul/templates/src/nsXULTreeBuilder.cpp:1070
2	xul.dll	nsContentTestNode::Constrain	content/xul/templates/src/nsContentTestNode.cpp:79
3	xul.dll	TestNode::Constrain	content/xul/templates/src/nsRuleNetwork.cpp:400
4	xul.dll	nsXULTemplateQueryProcessorRDF::Propagate	content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp:940
5	xul.dll	nsXULTemplateQueryProcessorRDF::OnAssert	content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp:769
6	xul.dll	CompositeDataSourceImpl::OnAssert	rdf/base/src/nsCompositeDataSource.cpp:1356
7	xul.dll	nsMsgRDFDataSource::assertEnumFunc	mailnews/base/src/nsMsgRDFDataSource.cpp:347
8	xul.dll	nsCOMArray_base::EnumerateForwards	objdir/mozilla/xpcom/build/nsCOMArray.cpp:74
9	xul.dll	nsMsgRDFDataSource::NotifyObservers	mailnews/base/src/nsMsgRDFDataSource.cpp:336
10	xul.dll	nsMsgFolderDataSource::OnItemAddedOrRemoved	mailnews/base/src/nsMsgFolderDataSource.cpp:791
11	xul.dll	nsMsgFolderDataSource::OnItemAdded	mailnews/base/src/nsMsgFolderDataSource.cpp:776
12	xul.dll	nsMsgMailSession::OnItemAdded	mailnews/base/src/nsMsgMailSession.cpp:162
13	xul.dll	nsMsgDBFolder::NotifyItemAdded	mailnews/base/util/nsMsgDBFolder.cpp:4970
14	xul.dll	nsMsgLocalMailFolder::CreateSubfolderInternal	mailnews/local/src/nsLocalMailFolder.cpp:580
15	xul.dll	nsMsgLocalMailFolder::CreateSubfolder	mailnews/local/src/nsLocalMailFolder.cpp:538 

hg@1 142 nsTreeRows::iterator
hg@1 143 nsTreeRows::FindByResource(nsIRDFResource* aResource)
hg@1 144{
hg@1 145 // XXX Mmm, scan through the rows one-by-one...
hg@1 146 iterator last = Last();
hg@1 147 iterator iter;
hg@1 148
hg@1 149 nsresult rv;
hg@1 150 nsAutoString resourceid;
mwu@79146 151 bool stringmode = false;
hg@1 152
hg@1 153 for (iter = First(); iter != last; ++iter) {
hg@1 154 if (!stringmode) {
hg@1 155 nsCOMPtr<nsIRDFResource> findres;
hg@1 156 rv = iter->mMatch->mResult->GetResource(getter_AddRefs(findres)); 


bp-01d55b3e-3978-44df-b012-3b2352130127
Mail will not download, I am transfering emails and deleting Them and will delete seamonkey and start over, nothing else has worked so far. I get a retr error message.

bp-b205a909-bef7-473f-ab2f-9e0772130107
Seit geraumer Zeit lssen sich keine Mails senden über Kabelbw. Haben sich Einstellungen geändert?

bp-72bb6605-ff1d-4902-97db-c3bd72121220
seamonkey crashed while I was configuring my gmail email account

bp-d26c5bec-404e-4a7a-9194-a54e52120423
Signed into gmail account using SeaMonkey email client. Crashed after asking for password.
https://crash-stats.mozilla.com/report/index/3ec396f6-13c5-4567-b790-2f0972131016
SeaMonkey 2.21 Crash Report [@ nsTreeRows::FindByResource(nsIRDFResource*) ]
crashed when running junk mail filter: Tools|Delete mail marked as junk in folder'.
NoOp's crash . ..

(In reply to NoOp from comment #1)
> https://crash-stats.mozilla.com/report/index/3ec396f6-13c5-4567-b790-
> 2f0972131016
> SeaMonkey 2.21 Crash Report [@ nsTreeRows::FindByResource(nsIRDFResource*) ]
> crashed when running junk mail filter: Tools|Delete mail marked as junk in
> folder'.

0	libxul.so	nsTreeRows::FindByResource(nsIRDFResource*)	content/xul/templates/src/nsTreeRows.cpp
1	libxul.so	nsXULTreeBuilder::HasGeneratedContent(nsIRDFResource*, nsIAtom*, bool*)	content/xul/templates/src/nsXULTreeBuilder.cpp
2	libxul.so	nsContentTestNode::Constrain(InstantiationSet&)	content/xul/templates/src/nsContentTestNode.cpp
3	libxul.so	TestNode::Constrain(InstantiationSet&)	content/xul/templates/src/nsRuleNetwork.cpp
4	libxul.so	nsXULTemplateQueryProcessorRDF::Propagate(nsIRDFResource*, nsIRDFResource*, nsIRDFNode*)	content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp
5	libxul.so	nsXULTemplateQueryProcessorRDF::OnAssert(nsIRDFDataSource*, nsIRDFResource*, nsIRDFResource*, nsIRDFNode*)	content/xul/templates/src/nsXULTemplateQueryProcessorRDF.cpp
6	libxul.so	CompositeDataSourceImpl::OnAssert(nsIRDFDataSource*, nsIRDFResource*, nsIRDFResource*, nsIRDFNode*)	rdf/base/src/nsCompositeDataSource.cpp
7	libxul.so	nsMsgRDFDataSource::assertEnumFunc(nsIRDFObserver*, void*)	mailnews/base/src/nsMsgRDFDataSource.cpp
8	libxul.so	nsCOMArray_base::EnumerateForwards(bool (*)(void*, void*), void*) const	objdir/mozilla/xpcom/build/nsCOMArray.cpp
9	libxul.so	nsMsgRDFDataSource::NotifyObservers(nsIRDFResource*, nsIRDFResource*, nsIRDFNode*, nsIRDFNode*, bool, bool)	objdir/mozilla/dist/include/nsCOMArray.h
10	libxul.so	nsMsgFolderDataSource::OnItemAddedOrRemoved(nsIMsgFolder*, nsISupports*, bool)	mailnews/base/src/nsMsgFolderDataSource.cpp 

hg@1 143 nsTreeRows::iterator
hg@1 144 nsTreeRows::FindByResource(nsIRDFResource* aResource)
hg@1 145 {
hg@1 146 // XXX Mmm, scan through the rows one-by-one...
hg@1 147 iterator last = Last();
hg@1 148 iterator iter;
hg@1 149
hg@1 150 nsresult rv;
hg@1 151 nsAutoString resourceid;
mwu@79445 152 bool stringmode = false;
hg@1 153
hg@1 154 for (iter = First(); iter != last; ++iter) {
hg@1 155 if (!stringmode) {
hg@1 156 nsCOMPtr<nsIRDFResource> findres;
hg@1 157 rv = iter->mMatch->mResult->GetResource(getter_AddRefs(findres)); 

 Was trying to set up Yahoo mail in Seamonkey
OS: Windows NT → All
topcrash (rank #10) for seamonkey 2.29

I suggest this is fairly reproducible.  Earliest SM version crash I find is 2.1.5 bp-70915421-1826-435e-b408-3af702140409

Me with SM 2.29.1 bp-50a708b0-e4d5-4b9b-a80d-768062141002 Crash Address 	0x1d. I deleted an imap and a pop account, added an imap account, think I clicked OK. crash.  Note - removing the accounts failed, the imap and pop accounts are still there.

another user "I had just entered the passwaord to logon to my IMAP server when it crashed".  Crash Address 0x5a5a5a5a

One of Karsten's crashes bp-82250399-f5e7-4388-ac6e-b6acc2140401

One of akoster's crashes bp-75d10eaa-d54d-4eff-9c14-9ece72140419 "Adding a new mail account in from the settings dialog"
Keywords: reproducible
Summary: crash in nsTreeRows::FindByResource → crash in nsTreeRows::FindByResource after adding new mail account
Crash Signature: [@ nsTreeRows::FindByResource(nsIRDFResource*)] → [@ nsTreeRows::FindByResource(nsIRDFResource*)] [@ nsTreeRows::FindByResource]

I no longer see crashes for 2.53.1 and up. Anyone still experiencing this?

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.