Last Comment Bug 857088 - Ensure the proper gap between tab-strip and titlebar when using large fonts
: Ensure the proper gap between tab-strip and titlebar when using large fonts
Status: RESOLVED FIXED
[Australis:M3]
:
Product: Firefox
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: All Windows 7
-- normal (vote)
: Firefox 28
Assigned To: Mike Conley (:mconley)
:
: Dão Gottwald [:dao]
Mentors:
Depends on:
Blocks: australis-tabs-win
  Show dependency treegraph
 
Reported: 2013-04-02 07:30 PDT by Mike Conley (:mconley)
Modified: 2013-11-18 13:23 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Reference screenshot (10.85 KB, image/png)
2013-04-17 08:23 PDT, Mike Conley (:mconley)
no flags Details
Patch v1 (1.94 KB, patch)
2013-04-22 06:28 PDT, Mike Conley (:mconley)
MattN+bmo: review+
Details | Diff | Splinter Review

Description User image Mike Conley (:mconley) 2013-04-02 07:30:29 PDT
From MattN's comment 108 in bug 813802:

> ... When the menubar is showing with Extra Large Fonts, there is a lot of
> unnecessary space between the tabs and menubar. I think it's still taking
> the height of the app & caption buttons (titlebar-content) into account but
> now that we don't put tabs under the app/caption buttons that doesn't seem
> right.  I'm wondering if I'm taking a step backwards here since the
> calculation has been discussed many times and I didn't note this before.
> This could move to a follow-up although it seems to hint that there are
> fundamental issues with the calculation.
Comment 1 User image Mike Conley (:mconley) 2013-04-17 07:27:12 PDT
When I was working on bug 813802, I was using this image for reference:

http://cl.ly/image/423u0z1O0c3x

It's possible I misunderstood, but I seem to recall shorlander saying that the top of the tab-strip needs to be 4px away from the bottom of either the menubar or the window buttons (just choose the "lowest" one).

Following up with shorlander to confirm.
Comment 2 User image Mike Conley (:mconley) 2013-04-17 08:23:47 PDT
Created attachment 738528 [details]
Reference screenshot

So I talked with shorlander, and this screenshot demonstrates the proper behaviour:

When the window buttons are taller than the menubar, the 4px distance should be between the tabstrip and the buttons.
Comment 3 User image Mike Conley (:mconley) 2013-04-22 06:28:23 PDT
Created attachment 740268 [details] [diff] [review]
Patch v1

This puts the 4px gap back between the tabstrip and the window buttons when the window buttons are larger than the menu.
Comment 4 User image Mike Conley (:mconley) 2013-04-22 10:18:19 PDT
I just checked with shorlander - the 4px gap is always supposed to be there in restored window mode, regardless of whether or not the menu is showing.
Comment 5 User image Matthew N. [:MattN] (PM if requests are blocking you) 2013-04-22 18:01:58 PDT
Comment on attachment 740268 [details] [diff] [review]
Patch v1

Review of attachment 740268 [details] [diff] [review]:
-----------------------------------------------------------------

Your recent patches haven't included HG headers btw.
Comment 6 User image Mike Conley (:mconley) 2013-04-23 07:55:31 PDT
Landed on UX as https://hg.mozilla.org/projects/ux/rev/1db126465f33
Comment 7 User image :Gijs (away until Feb 27) 2013-11-18 13:23:59 PST
https://hg.mozilla.org/mozilla-central/rev/1db126465f33

Note You need to log in before you can comment on or make changes to this bug.