[B2G][l10n][Portuguese] The password text prompt in the lock screen overruns the screen boundary

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: ckreinbring, Unassigned)

Tracking

({l12y})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: l10n)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 732443 [details]
Screenshot of passcode prompt in lock screen

Description:
A user with their device language set to Portuguese will see the lock screen text "Insira o código de segurança" poorly word wrapped, causing the end of the text to overrun the screen boundary.

Repro Steps:
1) Updated to Unagi Build ID: 20130402070202
2) Select Settings, then Language, then change the language to Portugues (do Brasil).
3) Restart the device.
4) Select Configurações then Bloqueio do aparelho.
5) Tap the Bloquear tela switch and the Bloquear com código switches if they are not already active.
6) If the Bloquear com código switch was tapped in the previous step, enter a code in both fields and select Criar.
7) Set the Exigir código to Imediatamente if it isn't already.
8) Press the power button twice to turn the display off and on.
9) Slide the lock bar up and select the unlock icon.
10) Observe the position of the text at the top of the screen.

Actual:
The text is wrapped in a way that causes the end of the text to overrun the screen boundary.

Expected:
The text is placed in a way that does not cause it to run outside the screen boundary.

Environmental  Variables:
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/ccec751a468e
Gaia: ee0bef61c0a25c806dd1eec5a4e047bc418a5f73

Notes:
Repro frequency: 100%
Q Analysts Test Team Priority: Pri 3
See attached screenshot for more info.
(Reporter)

Comment 1

5 years ago
Still repros on Unagi 1.0.1 Mozilla RIL.
Build ID: 20130425070201
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/5d454864b668
Gaia: 052253176f3ad495a1086e47a28fffbf07613388
Version #: 18.0
(Reporter)

Comment 2

5 years ago
Due to a change in the lock screen appearance, there is no longer a passcode prompt.  Resolving as Worksforme.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 3

5 years ago
This issue no longer reproduces on Leo V 1.1.0

Build ID: 20130718070206
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/7f6f4bc1a621
Gaia: f1d2e3fd806dc55f167c72ac8ef7a3b6baed915e
Platform Version: 18.1
RIL Version: 01.01.00.019.164
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.