xperia sola is not possible to install xpi

RESOLVED DUPLICATE of bug 969993

Status

Add-on SDK
General
P2
normal
RESOLVED DUPLICATE of bug 969993
5 years ago
4 years ago

People

(Reporter: Angelo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130307122903

Steps to reproduce:

Hi, I create an add-on with Add-on SDK firefox-22-dev-1-gbb071f7 (bb071f7ac300d9a3d8227148153c892efc94f0
It work fine when I launch it by ADB,
but when I create xpi file launching cfx xpi --force-mobile, installation on device fails
I tryied to install by file system, inside a webpage, but there are much error in device log.

Add on work well in fennec and in firefox mobile.

There is a way to emulate 'cfx run -a fennec-on-device -b ~/path/to/adb --mobile-app fennec --force-mobile ' inside the device?
I Can use an android shell, or also adb with command found on MSD don't work (command is like that adb shell am start -n org.mozilla.fennec/.App -d "file:///sdcard/a.xpi" ...)



Actual results:

Hi, I create an add-on with Add-on SDK firefox-22-dev-1-gbb071f7 (bb071f7ac300d9a3d8227148153c892efc94f0
It work fine when I launch it by ADB,
but when I create xpi file launching cfx xpi --force-mobile, installation on device fails
I tryied to install by file system, inside a webpage, but there are much error in device log.

Add on work well in fennec and in firefox mobile.

There is a way to emulate 'cfx run -a fennec-on-device -b ~/path/to/adb --mobile-app fennec --force-mobile ' inside the device?
I Can use an android shell, or also adb with command found on MSD don't work (command is like that adb shell am start -n org.mozilla.fennec/.App -d "file:///sdcard/a.xpi" ...)



Expected results:

Hi, I create an add-on with Add-on SDK firefox-22-dev-1-gbb071f7 (bb071f7ac300d9a3d8227148153c892efc94f0
It work fine when I launch it by ADB,
but when I create xpi file launching cfx xpi --force-mobile, installation on device fails
I tryied to install by file system, inside a webpage, but there are much error in device log.

Add on work well in fennec and in firefox mobile.

There is a way to emulate 'cfx run -a fennec-on-device -b ~/path/to/adb --mobile-app fennec --force-mobile ' inside the device?
I Can use an android shell, or also adb with command found on MSD don't work (command is like that adb shell am start -n org.mozilla.fennec/.App -d "file:///sdcard/a.xpi" ...)
(Reporter)

Updated

5 years ago
Component: General → Add-on Manager
OS: Linux → Android
Component: Add-on Manager → General
Product: Firefox for Android → Add-on SDK
Version: Firefox 21 → unspecified
Erik, want to look at this while you're looking at that other mobile bug?
Priority: -- → P2
https://developer.mozilla.org/en-US/Add-ons/SDK/Tutorials/Mobile_development

Or this is a dup of bug 969993
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 969993
You need to log in before you can comment on or make changes to this bug.