USB Mass Storage and USB Tethering don't work on leo phone

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dhylands, Assigned: leo.bugzilla.fw)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [NPOTB], URL)

(Reporter)

Description

5 years ago
The leo phone I have sets sys.usb.config (and persist.usb.config) to pc_suite,adb.

pc_suite seems to enable USB Mass Storage, and USB Tethering, but our software is expecting to see rndis to enable USB tethering and mass_storage to enable USB Mass Storage.

We also expect to be able to toggle these independently (i.e. there are separate controls in the settings app).

So we need to figure out how to deal with this.
(Assignee)

Comment 1

5 years ago
"pc_suite,adb" is the configuration name for LG USB driver.
It would enable following functions mass_storage,diag,modem,ndis,(adb).

We will change pc_suite to mass_storage, and also change functions to diag,modem,nmea,mass_storage,adb.

Anyways, I wonder if UMS and USB tethering doesn't work when enable at settings.
Flags: needinfo?(dhylands)
(Reporter)

Comment 2

5 years ago
When I tested UMS and USB tethering at the same time on our unagi phone, it didn't work, but I didn't spend any time trying to investigate what the issue was.
Flags: needinfo?(dhylands)

Comment 3

5 years ago
leo+ but NPOTB given comment 1
Assignee: nobody → leo.bugzilla.fw
blocking-b2g: leo? → leo+
Whiteboard: [NPOTB]

Updated

5 years ago
Duplicate of this bug: 857898
(Assignee)

Comment 5

5 years ago
We fixed this issue. Now, Leo uses config names as rndis and mass_storage.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Component: General → Builds

Updated

5 years ago
Flags: in-moztrap?

Comment 6

5 years ago
UCID: FM-006
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.