Closed Bug 857397 Opened 9 years ago Closed 9 years ago

Oak branch nightly builds not working

Categories

(Release Engineering :: General, defect)

x86_64
Windows 8
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bbondy, Unassigned)

References

Details

I currently ave Oak checked out and I'd like to test a couple of bugs that need to land for updater work.   To do this I have a couple of things blocking me.


1.

When I try to build with a clone of m-c onto oak I get failures with this:

> CalledProcessError: Command '['hg', 'unbundle',
>  'http://ftp.mozilla.org/pub/mozilla.org/firefox/bundles/oak.hg']' 
> returned non-zero exit status 255

Looking at the base URL I see bundles for elm but not oak.


2.

I haven't built a nightly build in around 3 months.  I don't fully understand the way the Nightly builds work but I think it looks back and makes a build against the previous Nightlies. So I think none are found and I can't use self serve API at the moment.  Someone has fixed this in the past for me. 

Thank you for your help!
Component: Release Engineering → Release Engineering: Automation (General)
QA Contact: catlee
The unbundle failure isn't fatal, just (perhaps) a bit slower - http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/oak-win32/1364952218/oak-win32-bm25-build1-build1.txt.gz is a successful build, after "Using bundles failed; falling back to clone."

But you might find it more workable to get IT to reset the repo to m-c tip, like you would if you had just booked it, rather than trying to live with the push of m-c you have now - with an enormous push making https://hg.mozilla.org/projects/oak/json-pushes?full=1&maxhours=24 time out (or whatever it's doing to cause it to just stop in the middle making busted json) so you can't even get tbpl to load, you're not heading toward having a good time. Especially since the current repo apparently has a rather messed up mobile/, which results in extreme carnage (and perhaps infinite retries) for Android tests.

Still have to get releng help to get that first nightly going, but it should otherwise make for a happier repo.
So from what i can tell the largest issue here was that 7274f4704020 was the tip push, but it was a closed head, while e53044984f1b is actually based on m-c and is fine.

Due to that tip push it is what we tried to build oak with and failed miserably, I still suggest to have IT reset for sanity though.
Summary: Oak branch tinderbox and nightly builds not working → Oak branch nightly builds not working
Depends on: 857561
Posted bug 857561 to reset oak as per Comment 1 and Comment 2.
I tried doing a blank push after the reset but I get nothing in tbpl.  I think maybe this is the problem:

> Special note: the first push to your newly cloned repo may not trigger builds 
> if the repo had been pushed to previously, which is bug 774862. If it does 
> not, please re-open the bug and move it to mozilla.org :: Release Engineering
>  with a comment 'Please restart the build scheduler'. 

Also can someone fire off or mark the nightly manually.

Thanks!
i just reset the build scheduler master, that should fix up any problems related to the reset
Thanks Ben! That fixes the tinderbox builds.
Just remaining is the Nightly builds now.
Looks like a my last attempt at a Nightly build worked:
https://tbpl.mozilla.org/?tree=Oak&rev=d359c9a9d7cb
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Blocks: 933958
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.