Intermittent test_seek.html | Test timed out

RESOLVED DUPLICATE of bug 981153

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 981153
5 years ago
4 years ago

People

(Reporter: philor, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #620598 +++

https://tbpl.mozilla.org/php/getParsedLog.php?id=21370361&tree=Mozilla-Inbound
Ubuntu VM 12.04 mozilla-inbound debug test mochitest-1 on 2013-04-02 12:17:06 PDT for push e0d063f04ee2
slave: tst-linux32-ec2-301

19:57:52     INFO -  SEEK-TEST: Started bug516323.indexed.ogv seek test 13
19:57:52     INFO -  202313 INFO TEST-PASS | /tests/content/media/test/test_seek.html | bug516323.indexed.ogv seek test 12: seeking: currentTime must be seekTime
19:57:52     INFO -  202314 INFO TEST-PASS | /tests/content/media/test/test_seek.html | bug516323.indexed.ogv seek test 13: seeking should default to false
19:57:52     INFO -  202315 INFO TEST-PASS | /tests/content/media/test/test_seek.html | bug516323.indexed.ogv seek test 13: currentTime must report seek target immediately
19:57:52     INFO -  202316 INFO TEST-PASS | /tests/content/media/test/test_seek.html | bug516323.indexed.ogv seek test 13: seeking flag on start should be true
19:57:52     INFO -  202317 INFO TEST-PASS | /tests/content/media/test/test_seek.html | bug516323.indexed.ogv seek test 13: seeking: currentTime must be duration
19:58:31     INFO -  [Parent 2060] WARNING: 1 sort operation has occurred for the SQL statement '0xa2dadd80'.  See https://developer.mozilla.org/En/Storage/Warnings details.: file ../../../storage/src/mozStoragePrivateHelpers.cpp, line 110
20:02:44     INFO -  202318 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_seek.html | Test timed out.
(screenshot)
20:02:57     INFO -  202319 INFO TEST-END | /tests/content/media/test/test_seek.html | finished in 325061ms
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Chris, please may you take a look at this?
Flags: needinfo?(cpearce)
I'll try to get to this in a couple of weeks.
Flags: needinfo?(cpearce)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
The recent spike of failures on Windows 7 here in test_seek seems to be in owl.mp3 and to a lesser extent in gizmo.mp4, test cases 12, 9, and 13 not finishing.

And this failure on Ubuntu is seek.ogv case 12 not finishing:

(In reply to TinderboxPushlog Robot from comment #48)
> msucan
> https://tbpl.mozilla.org/php/getParsedLog.php?id=23771663&tree=Fx-Team
> Ubuntu VM 12.04 fx-team debug test mochitest-1 on 2013-06-04 10:12:15
> slave: tst-linux32-ec2-357
> 
> 10:52:30     INFO -  147585 ERROR TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_seek.html | Test timed out.
(In reply to Chris Pearce (:cpearce) from comment #57)

> And this failure on Ubuntu is seek.ogv case 12 not finishing:
> 
> (In reply to TinderboxPushlog Robot from comment #48)
> > msucan
> > https://tbpl.mozilla.org/php/getParsedLog.php?id=23771663&tree=Fx-Team
> > Ubuntu VM 12.04 fx-team debug test mochitest-1 on 2013-06-04 10:12:15
> > slave: tst-linux32-ec2-357
> > 
> > 10:52:30     INFO -  147585 ERROR TEST-UNEXPECTED-FAIL |
> > /tests/content/media/test/test_seek.html | Test timed out.

In this case (seek.ogv/seek12.js), the log is:

10:47:38     INFO -  SEEK-TEST: Started seek.ogv seek test 12
10:47:39     INFO -  147573 INFO TEST-PASS | /tests/content/media/test/test_seek.html | seek.ogv seek test 12: seeking should default to false
10:47:39     INFO -  147574 INFO TEST-PASS | /tests/content/media/test/test_seek.html | seek.ogv seek test 12: currentTime must report seek target immediately
10:47:39     INFO -  147575 INFO TEST-PASS | /tests/content/media/test/test_seek.html | seek.ogv seek test 12: seeking flag on start should be true
10:47:39     INFO -  147576 INFO TEST-PASS | /tests/content/media/test/test_seek.html | seek.ogv seek test 12: seeking: currentTime must be seekTime

This means we're receiving the "seeking" event, but not the "seeked" event... (!!)
Comment hidden (Treeherder Robot)
Depends on: 882537
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
test_playback_rate.html and test_seek.html disabled on all platforms.
https://hg.mozilla.org/integration/mozilla-inbound/rev/81cae114022a
Whiteboard: [test disabled][leave open]
(In reply to TinderboxPushlog Robot from comment #73)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=25432727&tree=Mozilla-
> Central
> Ubuntu VM 12.04 x64 mozilla-central pgo test mochitest-1 on 2013-07-18
> 06:29:12
> revision: f26e4c26ce4a
> slave: tst-linux64-ec2-441
> 
> 06:55:57     INFO -  149824 ERROR TEST-UNEXPECTED-FAIL |
> /tests/content/media/test/test_seek.html | Test timed out.


The log from this failure is:

06:51:03     INFO -  SEEK-TEST: Started owl.mp3 seek test 13
06:51:03     INFO -  149821 INFO TEST-PASS | /tests/content/media/test/test_seek.html | owl.mp3 seek test 5: Got seeking event
06:51:03     INFO -  149822 INFO TEST-PASS | /tests/content/media/test/test_seek.html | owl.mp3 seek test 5: Got seeked event
06:51:03     INFO -  SEEK-TEST: Finished owl.mp3 seek test 5
06:51:03     INFO -  149823 INFO TEST-PASS | /tests/content/media/test/test_seek.html | [finished owl.mp3-121] Length of array should match number of running tests
06:55:57     INFO -  149824 ERROR TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_seek.html | Test timed out.

That means that seek13.js isn't even reaching loadedmetadata on owl.mp3 with the GStreamer backend.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 997844
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 151

4 years ago
Good times, back when this was disabled on all platforms.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
No longer depends on: 882537, 997844
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Whiteboard: [test disabled][leave open]
Duplicate of bug: 981153
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.