Text in image jumps for a frame about one second after loading or switching to a tab

RESOLVED DUPLICATE of bug 832400

Status

()

defect
RESOLVED DUPLICATE of bug 832400
6 years ago
6 years ago

People

(Reporter: jgilbert, Assigned: joe)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

6 years ago
Repro is easy for me on two Win7 machines:
1) Load the linked page.
2) Switch away from the tab.
3) Switch back to the tab with the image.
4) Watch the text carefully. About a second after switching back to the image, it should jump about a pixel upwards for a frame before reverting to its normal state.

At a guess, this sounds like something weird with the screenshotting code.

The image is resized (shrunk), so maybe it's an interaction with the downsampling code?

Most curiously, this seems to stop reproducing if you have the full-size image loaded in a background tab. It starts to reproduce again if you close the background tab with the full-size image.

Perhaps an issue with zooming and throwing out decoded image data?
Does flipping image.high_quality_downscaling.enabled fix the problem? It sounds a lot like that is the cause.
Reporter

Comment 2

6 years ago
(In reply to Timothy Nikkel (:tn) from comment #1)
> Does flipping image.high_quality_downscaling.enabled fix the problem? It
> sounds a lot like that is the cause.

Yep. Setting that pref to false makes the issue disappear, and re-enabling the pref makes it reappear.
Something like bug 832400 probably is about the same issue then.
Blocks: 486918
This would count as a regression?
Assignee: nobody → joe
Keywords: regression
Assignee

Updated

6 years ago
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832400
You need to log in before you can comment on or make changes to this bug.