Closed Bug 857481 Opened 7 years ago Closed 7 years ago

Don't display IDNs with mixed Simplified and Traditional Chinese characters as punycode

Categories

(Core :: Networking: DNS, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: smontagu, Assigned: smontagu)

References

Details

(Keywords: intl, Whiteboard: [leave open])

Attachments

(1 file)

See bug 854041 comment 12:

> I emailed Mark Davis. On Simplified vs. Traditional, he said:
> 
> "The test can only be applied if the characters are meant to be chinese.​ So
> "写真だけの結婚式​" is Japanese, and shouldn't be tested."
> 
> I asked if there was a programmatic way of telling, with only access to the
> label. He said:
> 
> "Not unless the domain is restricted to only allow Chinese names. I think,
> for example, that .CN doesn't allow arbitrary CJK characters, just the ones
> in Chinese."
> 
> He also said:
> 
> "B. The test for S vs T needs to be not whether the character has a T or S
> variant​, but whether the character is an S or T variant. In any event, we
> need to be much clearer in that section exactly how to use Unihan."
> 
> -- So I think we should remove the S vs T test for now, until it's more
> clear exactly what, if anything, we can do.
Attached patch PatchSplinter Review
Attachment #732850 - Flags: review?(honzab.moz)
Attachment #732850 - Attachment is patch: true
I would remove the code entirely. That's what source control is for :-)

Gerv
QA Contact: mwobensmith
Comment on attachment 732850 [details] [diff] [review]
Patch

Review of attachment 732850 [details] [diff] [review]:
-----------------------------------------------------------------

Sorry for delay.

r=honzab
Attachment #732850 - Flags: review?(honzab.moz) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/2089d4146c21
Flags: in-testsuite+
Whiteboard: [leave open]
Confirmed fixed, m-c, 2013-04-15.

I compared against the output of m-c 2013-03-22 and we no longer block this case. See bug 854041 for more details.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Duplicate of this bug: 984859
You need to log in before you can comment on or make changes to this bug.