Closed Bug 857588 Opened 7 years ago Closed 7 years ago

Search engine list empty when the profile is on a network drive.

Categories

(Toolkit :: OS.File, defect)

20 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED WORKSFORME
Tracking Status
firefox20 --- verified
firefox21 + verified
firefox22 --- verified
firefox23 --- unaffected

People

(Reporter: jean-francois.fournier, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.43 Safari/537.31

Steps to reproduce:

Update firefox to version 20.0


Actual results:

The adresse bar and search bar are not working anymore. The search engine list is empty and I cannot add or restore.


Expected results:

The adresse and the search bar should have worked.
I found the source of the problem. It's because my firefox profil is on a network drive.

I created a new profil (firefox.exe -P) and saved it on my local drive and it solve the issue. But I lost all my settings/add-ons/etc...
Regression window(m-c)
Good:
http://hg.mozilla.org/mozilla-central/rev/04abdd43606b
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121222 Firefox/20.0 ID:20121222031804
Bad:
http://hg.mozilla.org/mozilla-central/rev/ea373e534245
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121222 Firefox/20.0 ID:20121222051903
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=04abdd43606b&tochange=ea373e534245

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c3dd1c70b310
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121221 Firefox/20.0 ID:20121221095621
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/98dddd0da122
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20121221 Firefox/20.0 ID:20121221100222
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c3dd1c70b310&tochange=98dddd0da122
Suspected:
Bug 760036 - nsIBrowserSearchService should load metadata asynchronously


Fixed window(m-c)
Bad:
http://hg.mozilla.org/mozilla-central/rev/8693d1d4c86d
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130330 Firefox/22.0 ID:20130330030828
Fixed:
http://hg.mozilla.org/mozilla-central/rev/1932c6f78248
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130330 Firefox/22.0 ID:20130330163216
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8693d1d4c86d&tochange=1932c6f78248

Fixed window(m-i)
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/95c1cfb26fda
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130329 Firefox/22.0 ID:20130329075510
Fixed:
http://hg.mozilla.org/integration/mozilla-inbound/rev/76d14e65da84
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130329 Firefox/22.0 ID:20130329083007
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=95c1cfb26fda&tochange=76d14e65da84

Fixed by: 8db756a2bcd1	David Rajchenbach-Teller — Bug 846848 - UNC-formated paths. r=froydnj
Blocks: 760036
Status: UNCONFIRMED → NEW
Component: Untriaged → OS.File
Depends on: 846848
Ever confirmed: true
Keywords: regression
Product: Firefox → Toolkit
Thanks for the report, the fix is currently undergoing tests.
CC'ing QA here to see if they can help with verify if the uplifted patch in Bug 846848 helped here for Fx21.
(In reply to jean-francois.fournier from comment #1)
> I found the source of the problem. It's because my firefox profil is on a
> network drive.
> 
> I created a new profil (firefox.exe -P) and saved it on my local drive and
> it solve the issue. But I lost all my settings/add-ons/etc...

can you try our latest aurora build where the patch for https://bugzilla.mozilla.org/show_bug.cgi?id=846848#c40 is already existing on that channel and help verify if this issue is fixed for you ? Thanks
Yes, It worked with Aurora 22.0a2.
Thanks Jean-Francois.

Bhavana, I think we can call this bug "fixed by bug 846848".
(In reply to jean-francois.fournier from comment #6)
> Yes, It worked with Aurora 22.0a2.

Thanks for helping with verification here.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #7)
> Thanks Jean-Francois.
> 
> Bhavana, I think we can call this bug "fixed by bug 846848".

Thanks Anthony. Marked it accordingly.
Verified fixed FF 21b2 in bug 846848
Verified fixed FF 20.0.1 in bug 846848
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.