Disable Gamepad API for Firefox 22

RESOLVED FIXED

Status

()

Core
DOM
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ted, Assigned: ted)

Tracking

22 Branch
Points:
---

Firefox Tracking Flags

(firefox22+ fixed, firefox23+ verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Since bug 851547 didn't make the cut, we'll just disable the Gamepad API in configure. I'll post a patch in a little bit.
(Assignee)

Updated

5 years ago
tracking-firefox22: --- → +

Comment 1

5 years ago
Please make sure to change the target milestone for bug 604039 once this lands, for sanity.

Comment 2

5 years ago
Before release noting bug 604039 for Firefox 22, can you confirm that we'll be performing this disable at the end of the Aurora cycle?
(Assignee)

Comment 3

5 years ago
Yes, I'll get a simple patch up here today, should be a 1-liner. We can land it whenever you want during the Aurora cycle.
(Assignee)

Comment 4

5 years ago
Created attachment 736053 [details] [diff] [review]
Disable Gamepad API for Firefox 22

Pretty trivial patch.
Attachment #736053 - Flags: review?(mh+mozilla)
Attachment #736053 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 5

5 years ago
Comment on attachment 736053 [details] [diff] [review]
Disable Gamepad API for Firefox 22

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

User impact if declined: Would ship an unfinished Web API

Testing completed (on m-c, etc.): Trivial patch, builds fine locally.

Risk to taking this patch (and alternatives if risky): Minimal, any bustage should show up as immediate build bustage.

String or IDL/UUID changes made by this patch: None
Attachment #736053 - Flags: approval-mozilla-aurora?

Comment 6

5 years ago
Leaving this in the queue for now since it sounds like we'd like people to test on Aurora. Also nominating for tracking FF23, since it's not clear whether we'll ship the finished API in that version.
tracking-firefox23: --- → ?
(Assignee)

Comment 7

5 years ago
I'm hoping to be able to land bug 851547 in time for FF23, so we can simply pref it off instead of having to disable it at build time, but that has a dependency that it's waiting on.

I would like to make this available on Aurora for as long as is reasonable, but feel free to land this (or ask me to land it) whenever you need to.
Tracking for 23, leaving the disabling patch nominated for now, it can be landed later in the Aurora cycle.
tracking-firefox23: ? → +

Comment 9

5 years ago
Comment on attachment 736053 [details] [diff] [review]
Disable Gamepad API for Firefox 22

We're close to the end of the cycle. Approving this disable for Aurora 22.
Attachment #736053 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 10

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/4d2ac1883ce8
status-firefox22: --- → fixed
(Assignee)

Comment 11

5 years ago
bug 851547 landed in time for Firefox 24, but it didn't make Firefox 23, so we should land the disabling patch here for 23 (which I guess is beta as of today). I'm on vacation the rest of this week, but it's a simple patch if someone wants to land it. Otherwise I can do it when I'm back next week.
Flags: needinfo?(release-mgmt)

Updated

5 years ago
Attachment #736053 - Flags: approval-mozilla-beta+

Updated

5 years ago
status-firefox23: --- → affected
(Assignee)

Comment 12

5 years ago
Thanks, I should have just requested the approval.
Flags: needinfo?(release-mgmt)
(Assignee)

Comment 13

5 years ago
Fixed for 23:
https://hg.mozilla.org/releases/mozilla-beta/rev/480f6c51f45a

I'm marking this FIXED because 24 has the API behind a pref, so we should no longer need to disable it this way.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox23: affected → fixed
Resolution: --- → FIXED
Keywords: verifyme
Verified as fixed on FF 23 beta 9 (build ID: 20130725195523)

Used http://people.mozilla.com/~tmielczarek/combat/ page for testing.
Also, the dom.gamepad.enabled pref is not shown.
status-firefox23: fixed → verified
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.