Classes in CSS are case sensative

RESOLVED DUPLICATE of bug 49004

Status

()

RESOLVED DUPLICATE of bug 49004
17 years ago
17 years ago

People

(Reporter: frichard, Assigned: pierre)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)
BuildID:    2001061213

I don't know if this is a bug or not, but I noticed that CLASS=name names are
case sensative in Mozilla but apparently not in NS4.7 or IE5.x

Reproducible: Always
Steps to Reproduce:
Load the above URL, but also try saving and loading this small example:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN"
"http://www.w3.org/TR/REC-html40/loose.dtd">
<HTML>
<HEAD> 
<STYLE>
<!--
TABLE.dkblue{background:#669}
TD.dkblue,TH.dkblue,TR.dkblue TD,TR.dkblue TH,TABLE TR TD.dkblue,TABLE TR
TH.dkblue{background:#669;color:#FFF}
TABLE.white{background:#FFF}
TD.white,TH.white,TR.white TD,TR.white TH,TABLE TR TD.white,TABLE TR
TH.white{background:#FFF;color:#000}
TABLE.black,TD.cpyftr{background:#000}
TD.black,TH.black,TR.black TD,TR.black TH,TABLE TR TD.black,TABLE TR
TH.black{background:#000;color:#FFF}
TABLE.ltblue{background:#CCF}
TD.ltblue,TH.ltblue,TR.ltblue TD,TR.ltblue TH,TABLE TR TD.ltblue,TABLE TR
TH.ltblue{background:#CCF;color:#000}
-->
</STYLE>

<TITLE>TEST</TITLE>
</HEAD>

<BODY>

 <TABLE>
  <TD>
   <TABLE CLASS="black" >
    <TR>
     <TD>
      <!-- Class "WHITE" not defined ... -->
      <TABLE CLASS="WHITE" >

       <TR>
       <TD COLSPAN="2" CLASS="dkblue">DkBlue Class</TD>
       </TR>

       <!-- Upper case classes "LTBLUE" and "WHITE" are not defined -->
       <TR>
        <TD CLASS="LTBLUE">LTBLUE Class</TD>
        <TD CLASS="WHITE" >WHITE Class</TD>
       </TR>

       <!-- ... but the lower case classes "ltblue" and "white" are defined: -->
       <TR>
        <TD CLASS="ltblue">ltblue Class</TD>
        <TD CLASS="white" >white Class</TD>
       </TR>

      </TABLE>
     </TD>
    </TR>
   </TABLE>
  </TD>
 </TABLE>

</BODY>
</HTML>



Actual Results:  A table with some black cells is displayed.

Expected Results:  A table with some light blue and white cells should be
displayed.

Comment 1

17 years ago
The specs they that CSS classes should be case sensitive indeed.

*** This bug has been marked as a duplicate of 49004 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.