Closed Bug 857936 Opened 9 years ago Closed 9 years ago

ARIA columnheader/rowheader should inherit editable state

Categories

(Core :: Disability Access APIs, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla23
Tracking Status
firefox22 --- fixed

People

(Reporter: surkov, Assigned: surkov)

References

(Blocks 1 open bug)

Details

(Keywords: access, regression)

Attachments

(1 file)

Comment on attachment 733213 [details] [diff] [review]
patch

yeah, I should have thought of this :(
Attachment #733213 - Flags: review?(trev.saunders) → review+
https://hg.mozilla.org/mozilla-central/rev/bef79d45847a
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Comment on attachment 733213 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 835121
User impact if declined: Half-baked WAI-ARIA 1.0 compliance in this area.
Testing completed (on m-c, etc.): Yes
Risk to taking this patch (and alternatives if risky): None.
String or IDL/UUID changes made by this patch:None.
Attachment #733213 - Flags: approval-mozilla-aurora?
(In reply to Marco Zehe (:MarcoZ) from comment #4)

> Bug caused by (feature/regressing bug #): 835121

technically speaking it wasn't a regression from bug 835121
What version is ARIA compliance meant to go into first? Bug 343213 doesn't make that clear.

Also, does comment 5 mean to imply that this isn't a regression because ARIA is a new feature? Or is there another regressing bug?
(In reply to Alex Keybl [:akeybl] from comment #6)
> What version is ARIA compliance meant to go into first? Bug 343213 doesn't
> make that clear.

version of what? Firefox? I think we didn't even finish.

> Also, does comment 5 mean to imply that this isn't a regression because ARIA
> is a new feature? Or is there another regressing bug?

sort of, it's not a regression because we never did it this way (i.e we never exposed these states on these elements). This bug and bug 343213 are needed for the feature completeness.
Thanks, I was trying to understand the criticality of fixing this in FF21. We'll approve for uplift given the low risk profile, but don't feel this regression warrants tracking due to the low user impact.
Blocks: 835121
Keywords: regression
Attachment #733213 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.