feature request: add DuckDuckGo as default search engine

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
6 years ago
Last year

People

(Reporter: mutek, Unassigned)

Tracking

23 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130403 Firefox/23.0
Build ID: 20130403030841

Steps to reproduce:

I use the search engine from the Fiefox bar 


Actual results:

Google instead DuckDuckGo response


Expected results:

Firefox default to Google instead DuckDuckGo after first install, I expect that Mozilla use the fair DuckDuckGo than Google
Component: Untriaged → Search
OS: Linux → All
Hardware: x86 → All
We don't use DuckDuckGo, we use Google.

You might want to reset your search settings:
Open about:config
Search for browser.search.defaultenginename
Right click browser.search.defaultenginename and click reset
Search for browser.search.order.1
Right click browser.search.order.1 and click reset

Have you used firefox before? Did this happen immediately after install?
(In reply to Thomas [:Tad] from comment #1)
> We don't use DuckDuckGo, we use Google.

yes I know
this is the reason I opened a feature request:

change Google in favour of DuckDuckGo that's far away fair than Google

> 
> You might want to reset your search settings:
> Open about:config
> Search for browser.search.defaultenginename
> Right click browser.search.defaultenginename and click reset
> Search for browser.search.order.1
> Right click browser.search.order.1 and click reset
> 
> Have you used firefox before? Did this happen immediately after install?

I use Mozilla from 1990 when it was Netscape Navigator so...yes I know very well how to customize

The bug is a feature request to change Google in favour of DuckDuckGo as default search engine into Firefox

thank you
This will never happen. Most of our money comes from Google because we direct searches to them. Sorry :(

DuckDuckGo is only really useful on slower machines. Are there any reasons why you want DuckDuckGo to be default?
Flags: needinfo?(mutek)
Bugzilla is not the right place for a discussion about the default Engine.
FYI: Mozilla has a contract with google and gets money for Google as default search Engine.
Mozilla couldn't pay all the developer without a contract like this one.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mutek)
Resolution: --- → INVALID
I think this should be wontfix. BugZilla is fine for feature requests, but we just won't do this one.
Resolution: INVALID → WONTFIX
Duplicate of this bug: 1435599
You need to log in before you can comment on or make changes to this bug.