Closed Bug 858062 Opened 7 years ago Closed 5 years ago

All non-special IMAP folders gray and inaccessible. Can't drag or otherwise copy or move messages to them

Categories

(SeaMonkey :: MailNews: General, defect)

x86_64
Windows 7
defect
Not set

Tracking

(seamonkey2.17 affected, seamonkey2.20 affected)

RESOLVED DUPLICATE of bug 859269
Tracking Status
seamonkey2.17 --- affected
seamonkey2.20 --- affected

People

(Reporter: gah6, Assigned: dlech)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0 SeaMonkey/2.17
Build ID: 20130331213155

Steps to reproduce:

Recieved automatic update to SM 2.17.


Actual results:

After program restart, I launched SM Mail.  All IMAP folders (except for Inbox, Sent and Trash) are grayed out and italicized, as if the \NoSelect flag is set.  Unable to move any new messages into these folders, nor read any mail in them that is unindexed.

All folders are still perfectly accessible in Thunderbird 17.0.5 and webmail.  This problem seems isolated to the Seamonkey 2.17 update.  I've been able to recreate it on 5 different machines and 3 different accounts.


Expected results:

Folders should have retained the same properties they have had for years, allowing me to read and write to them.
I have learned a way to temporarily gain access to these folders.  

1)  Unsubscribe from desired folder(s)

2)  Go to Account Settings -> Server Settings -> Advanced -> Uncheck 'Show only subscribed folders"

3)  Resubscribe to folder(s)

4)  Recheck 'Show only subscribed folders' from step 2


This brings back the folder as it used to look, makes it fully readable, and I can move things into them.  However, as soon as you close down Seamonkey and go back in, the gray/italic/lock problem recurs.
Wayne: Do you see this in some version of Thunderbird 20 or later?

gah6: are you sure that your modem did not go down and that SeaMonkey did not go into offline mode shortly after the update?
Component: General → MailNews: General
gah6: Scrap that, I hadn't seen comment #1 when I typed comment #2.
No problem here when using TB daily or SM 2.1.7
tested 2.17a1 dated 1/4/2013 and still shows problem.
uncheck "show only subscribed folders" and problem goes away
Go Help->Restart with Add-ons Disabled. Are your IMAP folders still greyed out?
Yep, same problem with Add-Ons disabled.
tested:
- 2.17a1 dated 12/17/2013 failed
- today's 20.0a1 failed

Grant might test nightly between mid November and mid December to firm up regression range.

uncheck "show only subscribed folders", and keeping that setting, is a  workaround

uncheck "server supports folders..." has no effect. (our server does not support it)

I can't tell whether this is a SM regression, core regressions or mailnews regression. However, regarding mailnews, I could not reproduce in Thunderbird using same server, and I don't see any mailnews regression bugs filed since 11-1-2012 that might cause this
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Wayne Mery (:wsmwk) from comment #8)
> tested:
> - 2.17a1 dated 12/17/2013 failed
> - today's 20.0a1 failed

2.20a1 rather
https://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/
Do you know what the IMAP product the IMAP server is running and what version?
Are you comfortable with creating a new SeaMonkey profile to see if it happens on that profile too?
Are you comfortable downloading and testing different versions of SeaMonkey with a temporary profile to see when things broke?
Flags: needinfo?(gah6)
(In reply to Ian Neal from comment #10)
> Do you know what the IMAP product the IMAP server is running and what
> version?
sendmail 8.14.4

> Are you comfortable with creating a new SeaMonkey profile to see if it
> happens on that profile too?
I know Grant tried a new profile. no change

> Are you comfortable downloading and testing different versions of SeaMonkey
> with a temporary profile to see when things broke?

with "show only subscribed folders" checked ON ...
I may  have narrowed the regression range for 2.17a1 to 
2012-11-26 works
2012-11-27 fails
Flags: needinfo?(gah6)
(In reply to Wayne Mery (:wsmwk) from comment #11)
> (In reply to Ian Neal from comment #10)
> > Do you know what the IMAP product the IMAP server is running and what
> > version?
> sendmail 8.14.4
That would be the SMTP server, something like Dovecot or Cyrus.
I use Dovecot 2.1.15 and do not see the issue on trunk.

> with "show only subscribed folders" checked ON ...
> I may  have narrowed the regression range for 2.17a1 to 
> 2012-11-26 works
> 2012-11-27 fails
What does about:buildconfig give for the two source m-c revs?
Flags: needinfo?(vseerror)
irving's change  http://hg.mozilla.org/comm-central/rev/b8f425be58ed is relevant I think. But I don't why know it impacts SM and not Thunderbird.

And I have found comment 8 "uncheck "show only subscribed folders", and keeping that setting, is a workaround" to not be accurate. If I collapse account with show subscribed checked, the folders go non-select and I can't move messages from them.  It is the act of unchecking and rechecking "show only subscribed folders" that *temporarily* resolves the issue.  (reproduced @home using SM 2.19)
Irving, et al, any thoughts?  Require a protocol log?

I can provide a test account to our server if might help.
Flags: needinfo?(irving)
Keywords: reproducible
Summary: All IMAP folders gray and inaccessible → All non-special IMAP folders gray and inaccessible. Can't drag or otherwise copy or move messages to them
I have an imap:5 log for someone to look at.

But I was not able to reproduce using my test account :(
I don't build or run Seamonkey myself, but I'm testing this patch under TB now. If someone who builds SM wants to try this patch and let me know if it works, I'd appreciate the help.
Assignee: nobody → irving
Status: NEW → ASSIGNED
Attachment #735380 - Flags: feedback?(david)
Flags: needinfo?(irving)
Just happened to be looking at related bug 859269. Both are caused by changes in bug 799821.
Depends on: 799821
See Also: → 859269
(In reply to Wayne Mery (:wsmwk) from comment #16)
> I have an imap:5 log for someone to look at.
> 
> But I was not able to reproduce using my test account :(

Please send me the log. 

Also, does your server use mbox storage where folders cannot contain both messages and subfolders?
Flags: needinfo?(vseerror)
(In reply to David Lechner (:dlech) from comment #19)
> (In reply to Wayne Mery (:wsmwk) from comment #16)
> > I have an imap:5 log for someone to look at.
> > 
> > But I was not able to reproduce using my test account :(
> 
> Please send me the log. 

emailing you want I sent Irving, plus IRC

> Also, does your server use mbox storage where folders cannot contain both
> messages and subfolders?

correct, can't contain both. That checkbox in advanced settings is unchecked.
Flags: needinfo?(vseerror)
(In reply to Wayne Mery (:wsmwk) from comment #20)
> correct, can't contain both. That checkbox in advanced settings is unchecked.

OK. Bug 799821 should make it so that you don't need that unchecked any more. Try checking it and see if behavior changes.

If a folder contains subfolders, then the text should be gray rather than black (as in /NoSelect flag mentioned in comment #1). You should be able to right-click and add a "New Subfolder..."

The screenshot that Wayne emailed looks like what I would expect. The screenshot in Attachment 733313 [details] looks incorrect.
Comment on attachment 735380 [details] [diff] [review]
Use the same arguments for List() and Lsub() to make sure we get matching folders

Review of attachment 735380 [details] [diff] [review]:
-----------------------------------------------------------------

The parameter that you changed has to do with creating folders on the local hard drive. We don't want to do this because we are listing all folders and would end up with folders on the hard drive for imap folders that we are not subscribed to.
Attachment #735380 - Flags: feedback?(david) → feedback-
Wayne and Grant, try unsubscribing from all of your folders and then resubscribing. 

- Right-click the account and select "Subscribe..."
- Uncheck every folder that is checked and then click "OK" (Note: you will have to expand everything to get to subfolders)
- Open the same subscribe dialog again and resubscribe to the folders that you want

The list of subscribed folders are stored on the server and are completely independent of what is actually on the server. LSUB returns the values that you have saved whereas LIST return what is actually there. I am guessing that as some point in time, a setting change or upgrade on the server changed how it responds to the LIST command. As a result, what is returned by LIST does not match what is returned by LSUB. By unsubscribing everything, we are deleting all of these saved values and in resubscribing, we will be saving the same values that are returned by the LIST command.
Comment on attachment 735380 [details] [diff] [review]
Use the same arguments for List() and Lsub() to make sure we get matching folders

Review of attachment 735380 [details] [diff] [review]:
-----------------------------------------------------------------

My bad. In my last comment, I was remembering something else. It has only been 4 months since I wrote that patch you know :p

I think you are on to something here. I tried the patch earlier and it made no difference that I could see. However, it appears that my test server that I have setup does not require the directory, so of course it would not have made a difference.
Attachment #735380 - Flags: feedback- → feedback+
dlech, thanks for the info. I think irving is hoping you will finish off the patch.
Flags: needinfo?(david)
I'll give it a go.
Assignee: irving → david
Flags: needinfo?(david)
Why no IMAP log is provided yet...?

As seen in IMAP log attached to bug 859269, after patch of bug 799821, "LIST *" is issued before "LSUB *" when "Show subscribed folders only" is Checked, in order to work around problem due to unplesant behavior by UW-IMAP what written in bug 317597 comment #22.

If patch of bug 799821 works as designed, Tb perhaps uses \Noselect, \Noinferior etc.(may be \NoSelect, \NoInferiour) in "LIST *" response if exists in "LIST *" response.

When "Server supports folders that can contain subfolders and messages" is Unchecked, I guess that decision on noselect or non-noselect, subfolder is creatable or not, mail can be contained or not, etc. by Tb based on "subfolder exists or not" etc. is done only when \Noselect, \Noinferior etc. doesn't exist. If \Noselect, \Noinferior etc. exists in LSUB or LIST response("doesn't exist in LSUB response" is already known), Tb perhaps uses it.

Is you UW-IMAP server peoperly configured?
Does your UW-IMAP server correctly/consistently return(or doesn't return) \Noselect or \Noinfeior etc. to "LIST %", "LIST %/%"(used by Tb when "Show only subscribed folder" is Unchecked) and "LIST *"(used by Tb after patch of 799821 when "Show only subscribed folder" is Checked)?
Appears to be fixed by Bug 859269.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859269
You need to log in before you can comment on or make changes to this bug.