Closed Bug 858109 Opened 7 years ago Closed 6 years ago

PDF table cell background color pink when should be grey gradient

Categories

(Firefox :: PDF Viewer, defect, P3)

22 Branch
x86_64
Windows 7
defect

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: joel, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22

Steps to reproduce:

Loaded the attached file.


Actual results:

Background color for first columns of attached PDF renders as PINK.


Expected results:

Background color for those same columns should have rendered as slightly different grey gradients (no color).
The first row's gradients are a three color gradient from top down (dark, lighter, darker) and the second row's gradients are 2 color from upper left to bottom right (light to dark)

I noticed the problem in Firefox 20 release and confirmed the problem was in Firefox 22 nightly so I believe it to be a current bug in pdf.js.
Component: Untriaged → PDF Viewer
Confirmed with Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130405 Firefox/23.0 ID:20130405103453 CSet: 40a228f74389 + PDF.js 0833.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern]
Status: NEW → RESOLVED
Closed: 6 years ago
Depends on: 965861
Resolution: --- → FIXED
Whiteboard: [pdfjs-c-rendering][pdfjs-d-shading-pattern] → [pdfjs-c-rendering][pdfjs-d-shading-pattern][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4192
Target Milestone: --- → Firefox 29
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.