Review buttons do not work when more themes are loaded

VERIFIED FIXED in 2013-04-11

Status

Marketplace
Reviewer Tools
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Cristian Boldan, Assigned: ngoke)

Tracking

2013-04-11
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
Steps to reproduce:
1. Load Theme Review Queue landing page https://marketplace-dev.allizom.org/reviewers/themes/queue/
2. Review all the listed themes but don't press the Commit Reviews buttons.
3. Press the Load More button.
4. Try to review the loaded themes.

Expected results:
User is able to review the loaded themes with no problems.

Actual results:
The review buttons for the loaded themes do not work.

Notes/Issues:
Verified on FF23 (Win 7).
Screencast for this issue http://screencast.com/t/gnc68wNbb
Assignee: nobody → ngoke
Priority: -- → P1
(Assignee)

Comment 1

5 years ago
https://github.com/mozilla/zamboni/commit/aa059333679d9de2ee7c90d95ab607fcbe442bf6
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

5 years ago
Buttons now work but, it reviews all the themes that were loaded after the Load More buttons is pressed http://screencast.com/t/pfa7xpVt
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 3

5 years ago
Hopefully, this fixes it.

https://github.com/mozilla/zamboni/commit/1fe3315ed027452ddab02c5960ff7c3182361976
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

5 years ago
Verified as fixed in https://marketplace-dev.allizom.org/reviewers/themes/queue/ on FF23 (Win 7).
Postfix screencast http://screencast.com/t/N8OksL5q
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

5 years ago
I have noticed that the issue is reproducing in the Flagged Themes page as described in Comment 2 https://marketplace-dev.allizom.org/reviewers/themes/queue/flagged . Should I file a new bug for this page or reopen this one?
Please see screencast http://screencast.com/t/x2UmzEOMu
Target Milestone: 2013-04-04 → 2013-04-11
(Assignee)

Updated

5 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

5 years ago
https://github.com/mozilla/zamboni/commit/ca58182a045246d882f05d7d4e571db2fd19aed6
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 7

5 years ago
Issue is reproducing again in https://marketplace-dev.allizom.org/reviewers/themes/queue/ on FF23 (Win 7), but it's not reproducing in https://marketplace-dev.allizom.org/reviewers/themes/queue/flagged.
Please see screencast http://screencast.com/t/bzdQ4gZv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

5 years ago
thanks for catching all these!

https://github.com/mozilla/zamboni/commit/f6f5befadd9d676b09bd6d341d803ea189dd2d8e
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

5 years ago
Fixed due to design changes. The Load More button has been removed ( https://bugzilla.mozilla.org/show_bug.cgi?id=841188 ).
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.