[Leo] Call Settings/Cellular and Data show "SIM Card not ready"

RESOLVED DUPLICATE of bug 859260

Status

RESOLVED DUPLICATE of bug 859260
6 years ago
6 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

Attachments

(1 attachment)

Created attachment 733494 [details]
Screenshot of issue

Seen while running:Gecko  

http://hg.mozilla.org/releases/mozilla-b2g18/rev/da523063aa7b
Gaia   a845be046c5d3cb077e3c78f963ca5c079e7ab3d
BuildID 20130404070202
Version 18.0

STR:
1. Load a AT&T SIM card
2. Observe attached screenshot

Comment 1

6 years ago
Do we need to add one more status in RIL for this bug?
Flags: needinfo?(allstars.chh)
Please enable log for RIL (Bug 811605) and attach it.
Flags: needinfo?(allstars.chh)

Comment 3

6 years ago
I have similar bug dedicated happens on leo device.

https://bugzilla.mozilla.org/show_bug.cgi?id=857462

I can't make sure it because I don't have any log info in this bug.
I am having trouble flashing the RIL build on the Leo device. The next time I can do so I can get you a log.
Last night I edit the user.js file and now the phone won't start up and I have to reflash it - so I am not sure whether or not I will be able to get useful logging information in this situation.

Comment 6

6 years ago
(In reply to Marcia Knous [:marcia] from comment #5)
> Last night I edit the user.js file and now the phone won't start up and I
> have to reflash it - so I am not sure whether or not I will be able to get
> useful logging information in this situation.

The way I modified the user.js to enable RIL log manually.

1. adb pull /system/b2g/defaults/pref/user.js
2. vim user.js
3. Modify the below statement to true 
    pref("ril.debugging.enabled", false);
4. adb push user.js /system/b2g/defaults/pref/
5. adb reboot

I believe the above steps can get useful RIL information.

Comment 7

6 years ago
User unable to dial outbound calls, but may receive incoming calls.

Leo v1.1.0 Mozilla and Commercial RILs:
Build ID: 20130501070205
Gecko: 765d296cff66
Gaia: e420d71c9528786621f176fb4ce67d291e0a530e

Comment 8

6 years ago
recommending escalation to Pr1
blocking-b2g: --- → leo?
Keywords: smoketest

Comment 9

6 years ago
possible a duplicate of 859260
Triage 5/3 leo+.
Please can anyone confirm if this is a dup of bug 859260 then we can close one off as dupe.
blocking-b2g: leo? → leo+
Yup its a definite dupe
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859260
You need to log in before you can comment on or make changes to this bug.